Assertion failure: cx->isExceptionPending() running testcase from bug 1269755 with --ion-eager

RESOLVED DUPLICATE of bug 1364908

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1364908
2 years ago
8 days ago

People

(Reporter: jonco, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
The following testcase fails when run with: --ion-eager --ion-offthread-compile=off

oomTest(function() { eval(`
   for (y = 0; y < 3; y++ ) {
    SignedRightShift(y );
  }
function Mask( b, n ) {
  b = ToUint32BitString( b );
  b = b.substring( b.length - n );
  b = "0" + b;
}
function ToUint32BitString( n ) {
  var b = "";
  for ( var p = 0; p < 29; p++ ) {
      b += "0";
  }
  return b;
}
function SignedRightShift(a ) {
  a = Mask( a, 5 );
}
`)});

For some reason it seems to depend on the path of the testcase, with an longer absolute path failing every time, but a relative path not:

~/clone/dev/js/src$ ./optdebug-build/shell --ion-eager --ion-offthread-compile=off testcase.js
~/clone/dev/js/src$ ./optdebug-build/shell --ion-eager --ion-offthread-compile=off /home/jon/clone/dev/js/src/testcase.js
Assertion failure: cx->isExceptionPending() (Thunk execution failed but no exception was raised - missing call to js::ReportOutOfMemory()?), at /home/jon/clone/dev/js/src/builtin/TestingFunctions.cpp:1373
Segmentation fault (core dumped)
(Reporter)

Updated

2 years ago
Priority: -- → P3
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Jon, which changeset does this reproduce on? I tried with an absolute path on m-c tip rev d02d14a3dd6e with --enable-debug, but failed to reproduce this.
Flags: needinfo?(jcoppeard)
Keywords: assertion, testcase
Summary: Assertion failure: cx->isExceptionPending() runing testcase from bug 1269755 with --ion-eager → Assertion failure: cx->isExceptionPending() running testcase from bug 1269755 with --ion-eager
I also retried on rev 560b2c805bf7 which is what was referenced in bug 1269755 comment 4, but couldn't reproduce with --ion-eager.

=> WFM
Status: NEW → RESOLVED
Last Resolved: a month ago
Flags: needinfo?(jcoppeard)
Resolution: --- → WORKSFORME
Reopening for Iain to recheck, since he could reproduce bug 1066759 and I (initially) couldn't.
Status: RESOLVED → REOPENED
Flags: needinfo?(iireland)
Resolution: WORKSFORME → ---

I could reproduce this in rev 560b2c805bf7, but not in central. Looking at it in RR, the last OOM before crashing -- that is, the one that failed to call ReportOutOfMemory -- was this allocation in PrepareOSRTempData.

Nicolas added a call to ReportOutOfMemory as part of bug 1364908.

Closing as duplicate.

Status: REOPENED → RESOLVED
Last Resolved: a month ago8 days ago
Flags: needinfo?(iireland)
Resolution: --- → DUPLICATE
Duplicate of bug: 1364908
You need to log in before you can comment on or make changes to this bug.