Closed Bug 1305773 Opened 3 years ago Closed 3 years ago

nothing happens when clicking on AMP links in Google Search results

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jaws, Unassigned)

References

Details

(Whiteboard: [needsdiagnosis])

When searching for: wealthiest community in America
the first result is:

America's Richest (and Poorest) Towns - 24/7 Wall St.
247wallst.com/special-report/2016/05/09/americas-richest-and-poorest-towns/
AMP - May 9, 2016 - Scarsdale, New York is the richest town in America with a median annual household income of $241,453.

Clicking the link has no action and there are no errors in the web console or browser console. This only happens with links that have AMP under the header.

Seen on Windows 10 52.0a1 (2016-09-20) (64-bit)
Dennis, can you take a look?
Flags: needinfo?(dschubert)
Whiteboard: [needsdiagnosis]
Blocks: 1300787
I've tried bisecting this with mozregression but the target keeps moving and I'm narrowing it down to bugs that don't make any sense (bug 1244227 and bug 1281547).
Reproduces in Safari, Opera and Edge for me as well.
I've poked around a bit since I initially thought this was related to some A/B testing I've seen Google doing recently. However, I never saw the AMP logo below the header, so I fired a search to see what's up with that. I found [0], and apparently this was a bug and Google either is aware of it and already fixed it - at least I cannot reproduce.

Jared, can you still reproduce?

[0]: https://twitter.com/cramforce/status/780824406201249793
Flags: needinfo?(dschubert) → needinfo?(jaws)
I don't see AMP search results for that query anymore so I think Google pulled it and is investigating. Closing per the link in comment #4.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(jaws)
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.