Closed Bug 130589 Opened 21 years ago Closed 2 months ago

[UX] Provide UI to allow users to print preview a given frame

Categories

(Toolkit :: Printing, enhancement, P4)

enhancement

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: rods, Unassigned)

References

Details

(Whiteboard: [adt3])

 
Status: NEW → ASSIGNED
Keywords: nsbeta1
Target Milestone: --- → mozilla1.0
nsbeta1+. This is needed to allow the user to print-preview a frame within a
frameset document
Keywords: nsbeta1nsbeta1+
adt3 per adt triage
Whiteboard: [adt3]
Moving to nsbeta1-.
Keywords: nsbeta1+nsbeta1-
Priority: -- → P1
Target Milestone: mozilla1.0 → Future
*** Bug 153483 has been marked as a duplicate of this bug. ***
*** Bug 162938 has been marked as a duplicate of this bug. ***
*** Bug 234581 has been marked as a duplicate of this bug. ***
Severity: normal → enhancement
Assignee: rods → nobody
Status: ASSIGNED → NEW
QA Contact: sujay → printing
OS: Windows 2000 → Unspecified
Priority: P1 → P4
Hardware: x86 → Unspecified
Summary: Enable the UI to choose which Frameset to show in PrintPreview → [UX] Provide UI to allow users to print preview a given frameset frame
Duplicate of this bug: 913863

The Core printing code would already support this. Moving over to Toolkit since this is really a decision for the frontend product folks. I imagine the obvious UI would be a new Print Preview Frame item in the frame specific context menu alongside Print Frame.

Also changing the bug title to use "frame" instead of "frameset" since over the last 17 years framesets have become very rare, so this is primarily of interest for iframe nowadays.

Component: Print Preview → Printing
Product: Core → Toolkit
Summary: [UX] Provide UI to allow users to print preview a given frameset frame → [UX] Provide UI to allow users to print preview a given frame
Target Milestone: Future → ---
Version: Trunk → unspecified

This behavior is the default now when you right click over the frame and use the context menu (This Frame > Print Frame...).

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.