If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Confusion of hotmail accounts with 2 or more hotmail tabs.

RESOLVED DUPLICATE of bug 117222

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 117222
16 years ago
2 years ago

People

(Reporter: dmoz1, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

If I have more than one hotmail account open on 2 different tabs, the tabs
*sometimes* get confused and opens information on the same account. e.g clicking
on inbox on one account can open the inbox of the other account.

Also (probably related and more reproducable) if I go direct to a hotmail page
with a hotmail account already open in one tab - hotmail wants me to enter
current password (for open account). I do not get this problem if I use 2 IE5
browsers. It looks like a confusion of cookies, but whether this is fixable in
Mozilla, or a hotmail problem I do not know.

Reproducible: Sometimes
Steps to Reproduce:
1. Login to hotmail on one tab.
2. Create New tab.
3. Login with a different hotmail account on New tab.


Actual Results:  As in description.

Expected Results:  I would expect Mozilla Tabs to act as different browsers in
terms of stored information.  (Just as they have seperate histories).
(Assignee)

Comment 1

16 years ago
Can you reproduce this bug with two mozilla windows? I suspect you can.

cc'ing morse for session cookies expert knowledge.

Morse, as far as I know, session cookies are visible throughout the entire
browser app. Should they be per-window (or per browsing instance, e.g. tab)
instead? Or am I misunderstanding something completely here?

Comment 2

16 years ago
jag's question about two mozilla windows was right on the mark -- I was about to 
say that as a statement as I started reading this bug report.

Cookies are not and never have been (since the beginning of netscape browsers) 
on a per window basis -- they apply to the entire browser.  So you cannot log on 
to any site as one user in one window and another user in another window and 
expect things to work correctly.  The same goes for tabs.  And I'd be very 
reluctant to change this behavior for fear of breaking some websites.

You say that you don't get this behavior when running two IE5 browsers 
simultaneously.  You won't get this behavior when running two netscape browsers 
simultaneously either if each browser is using a different profile.
(Assignee)

Comment 3

16 years ago
Well, IE doesn't have a notion of profiles, and Mozilla doesn't support running
two instances simultaneously, does it? I thought it would detect that case (DDE
on Windows) and just open another window.

Comment 4

16 years ago
Mozilla does support running two browsers simultaneously if they have two 
different exe files.
(Reporter)

Comment 5

16 years ago
I have tried 2 running browsers (different copies of the executable) on winNT. I
have set up 2 different profiles which I get the option of using. However when I
start the second executable I do not get the option to use a different profile.
I do not think that there is any way of selecting a profile from within a
running browser? 

 Do I need to create a second installation to a different directory - not just a
second copy of the executable?
i.e. Is there any way of running 2 different profiles on the same machine? 

I accept that this is now not a bug as such, because the Mozilla browser is
designed this way. But some work around should be possible now - and maybe a
future option to save cookies as entire session cookies or window (tab) cookies ?
(This would have to go along with the ability to save tab layout (as galeon
does?) - unless I am missing something and this can already be done).

Thankyou for your time and the work you put into this project.

Comment 6

16 years ago
cc'ing dp because he might be able to answer the question about rinning two 
browsers simultaneously with two separate profiles.

The other thing is dynamic profile switching, which we currently do not have but 
I know conrad has worked on so I'm copying him as well.

Comment 7

16 years ago
Two separate exes can run two separate instances of mozilla with different
profiles. But that is so uncommon - mostly developers are the ones who do it
(run one Netscape and another debug-mozilla build)

The bug seems to be more about one instance, two tabs. I dont think the expected
behaviour by the user is correct. But:

"Also (probably related and more reproducable) if I go direct to a hotmail page
with a hotmail account already open in one tab - hotmail wants me to enter
current password (for open account)."

Why would that happen ?

Comment 8

16 years ago
as to the original assertions, at least half of them are wrong.
they have a single global history, and a single bookmark file, and a single 
cache and a single cookie file. [they do have individual navigation histories, 
but that's just for navigation, and IE breaks this rule so you really don't 
want to go there].

Also, I suspect that IE can be made to break if you configure it not to browse 
in new process. But I don't have a hotmail account nor do i have any interest 
in getting multiple accounts (I could play with bugzilla, but I don't want to 
disable browse in new process).

As to later comments... Comment 3 by jag
Well, IE doesn't have a notion of profiles - false.
at the very least, you can run IE as a different user and pick up that user's 
profile [NT].

Mozilla doesn't support running two instances simultaneously, does it? - This 
depends on your definition of support, and does and ... :-) -- more later

I thought it would detect that case (DDE on Windows) and just open another 
window. - True, if possible, however there are various ways to negate this.

Comment 4 by Morse
Mozilla does support running two browsers simultaneously if they have two 
different exe files. - Wrong logic:
the issue isn't the name on disk, it's the app internal name.  so renaming 
mozilla.exe to foopy.exe won't help.  you'd have to rebuild the application or 
otherwise twiddle the app. 

re Comment 5, http://211.9.115.254/switcher2.zip will let you run at least 5 
mozillas (one per workspace) on nt.  it doesn't require changing the app 
internal name.

given you're on NT, i'd suggest switcher instead. source is included.  note 
that switcher also works for nc4 :)

Is there a useful bug here that isn't covered elsewhere? imo there is not.  
suggest: invalid/wontfix.
(Reporter)

Comment 9

16 years ago
Re: Question in Comment #7 (and comment in para 2 of #8)

I get the same behaviour as Mozilla if I I do not log out of microsoft passport
before going to other pages within a *single* IE session. If i try to open a new
hotmail session in the same browser sesion, it requests password to the unclosed
account. I would guess that IE always looks for a cookie describing the login
account. However if it finds that a cookie is in use by a different browser
session, it ignores it and asks for login + password. 

Re: #8

Ok. Thanks for all of the information. 

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: sairuh → pmac

Comment 10

15 years ago
won't fix: before getting to another hotmail account passport disconect. 
Blocks: 114158

Comment 11

15 years ago
dub bug 187790 (?)

Comment 12

15 years ago
oops! check dub of 
bug 170396

Comment 13

14 years ago
It looks to me like an implementation of bug 117222 would fix this.

Comment 14

14 years ago
*** Bug 244811 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 117222 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
No longer blocks: 114158
You need to log in before you can comment on or make changes to this bug.