source step busted at |configure|

RESOLVED FIXED in seamonkey2.46

Status

defect
RESOLVED FIXED
3 years ago
10 months ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

unspecified
seamonkey2.46
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 2 obsolete attachments)

TOOLTOOL_DIR issue?  (just filing this bug.. will think on it later)

checking for a shell... /bin/sh
checking for host system type... x86_64-pc-linux-gnu
checking for target system type... x86_64-pc-linux-gnu
checking whether cross compiling... no
checking for pkg_config... not found
DEBUG: pkg_config: Trying /builds/slave/rel-c-rel-source/comm-release/mozilla/gtk3/usr/local/bin/pkg-config
ERROR: Cannot find pkg_config
*** Fix above errors and then restart with\
               "make -f client.mk build"
make: *** [configure] Error 1
Blocks: SM2.46
oh yes. in light that I remembered somehow that I have some patch 
somewhere in some bug that removes the no_tooltool=1 from
the mozconfigs but have forgotten about which bug this belongs
to, I'm going to attach a patch here that removes the no_tooltool=1 
from the release mozconfigs.

This means..   build #2. yup.. build 2.
will do a post-land-review.. or if someone can review this post-haste..
whichever option is the quickest.
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #8795600 - Flags: review?(philip.chee)
Attachment #8795600 - Flags: review?(iann_bugzilla)
Attachment #8795600 - Flags: review?(bugspam.Callek)
Comment on attachment 8795600 [details] [diff] [review]
[mozconfigs] remove no_tooltool=1 [checked-in]

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: none. just can't build in automation
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: none

Basically we need this patch so that our release builders
can use the tooltool packages.  

Note: the l10n-mozconfig changes were fixed by an earlier patch
so transplanting this patch from c-r to others
will need some finesse.
Attachment #8795600 - Flags: approval-comm-release?
Attachment #8795600 - Flags: approval-comm-beta?
Attachment #8795600 - Flags: approval-comm-aurora?
Comment on attachment 8795600 [details] [diff] [review]
[mozconfigs] remove no_tooltool=1 [checked-in]

r/a=me for all repos
Attachment #8795600 - Flags: review?(iann_bugzilla)
Attachment #8795600 - Flags: review+
Attachment #8795600 - Flags: approval-comm-release?
Attachment #8795600 - Flags: approval-comm-release+
Attachment #8795600 - Flags: approval-comm-beta?
Attachment #8795600 - Flags: approval-comm-beta+
Attachment #8795600 - Flags: approval-comm-aurora?
Attachment #8795600 - Flags: approval-comm-aurora+
Attachment #8795616 - Flags: review?(philip.chee)
this depends on the "disable compile env during source step"'s mozconfig.
Attachment #8795622 - Flags: review?(bugspam.Callek)
Attachment #8795600 - Flags: review?(philip.chee) → review+
Comment on attachment 8795616 [details] [diff] [review]
[mozconfig] disable compile env during source step

Looks OK
> +export MOZ_DEBUG_SYMBOLS=1
but you might want to add:
ac_add_options --enable-debug-symbols
even if this is a dummy file.
Attachment #8795616 - Flags: review?(philip.chee) → review+
Attachment #8795616 - Attachment is obsolete: true
Attachment #8795628 - Flags: review+
Comment on attachment 8795628 [details] [diff] [review]
[mozconfigs] disable compile env for source step.

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: source step in release process doesn't need the compile env, so it's better to disable it.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch: none
Attachment #8795628 - Flags: approval-comm-release?
Attachment #8795628 - Flags: approval-comm-beta?
Comment on attachment 8795628 [details] [diff] [review]
[mozconfigs] disable compile env for source step.

a=me for comm-beta comm-release and anything else.
Attachment #8795628 - Flags: approval-comm-release?
Attachment #8795628 - Flags: approval-comm-release+
Attachment #8795628 - Flags: approval-comm-beta?
Attachment #8795628 - Flags: approval-comm-beta+
https://hg.mozilla.org/releases/comm-release/rev/762fbf1fa7f3ec770326b73bddc1e6e5d1a415c4
Bug 1305912 - Disable compile environment for source step. r+a=RattyAway
https://hg.mozilla.org/build/buildbot-configs/rev/77fb9f87b9f175d3e8b845848b1df4720f510148
Bug 1305912 - Use the source mozconfig instead of the release mozconfig for the source step.
something within the source mozconfig is bugging the source step.
Attachment #8796044 - Attachment is obsolete: true
Attachment #8796051 - Flags: review?(bugspam.Callek)
Attachment #8795600 - Attachment description: [mozconfigs] remove no_tooltool=1 → [mozconfigs] remove no_tooltool=1 [checked-in]
Attachment #8795600 - Flags: review?(bugspam.Callek)
Attachment #8796051 - Flags: review?(bugspam.Callek)
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.46
Attachment #8795622 - Flags: review?(bugspam.Callek)
You need to log in before you can comment on or make changes to this bug.