Search includes MailWindowOverlay which includes viewZoomOverlay which throws an exception.

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: timeless, Assigned: neil@parkwaycc.co.uk)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
yesterday morning cvs build, freebsd, littlemozilla theme.
./mozilla -mail, search>search messages

[Exception... "'[JavaScript Error: "this.bundle has no properties" {file: "chrome://communicator/content/viewZoomOverlay.js" line: 49}]' when calling method: [nsIDOMEventListener::handleEvent]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "<unknown>"  data: yes]

What should be done?  probably at least one of these three things:
a. make search not include mailWindowOverlay
b. make mailWindowOverlay not include viewZoomOverlay
c. make viewZoomOverlay not trigger this exception :-)

Comment 1

16 years ago
(a) is my suggestion, though I could see (b) as an option too.

If you don't need the text zoom code, try to avoid it (and its JS!) getting
overlaid. this goes for most of the overlays. The xul itself won't hurt too
much, because whatever can't get overlayed won't get built, but the JS will
always be there taking space.

This might mean moving the viewZoomOverlay.xul out of mailWindowOverlay and
moving it into the mail xul files (below the mailWindowOverlay include) that
actually do want this menu. Or it might mean refactoring mailWindowOverlay. I'll
leave that up to you guys.
(Assignee)

Comment 2

16 years ago
Last time I looked Search only needed the status bar XUL from mailWindowOverlay
(Assignee)

Comment 3

16 years ago
Created attachment 108737 [details] [diff] [review]
Proposed Patch

Removes mailWindowOverlay and inlines the required elements.
(Assignee)

Updated

16 years ago
Attachment #108737 - Flags: superreview?(bienvenu)
Attachment #108737 - Flags: review?(jaggernaut)

Comment 4

16 years ago
I'm a little leary of going this direction as the search window takes on more of
the attributes of a real window instead of less, but as long as you've made sure
everything still works, I can sr it.

Comment 5

16 years ago
Comment on attachment 108737 [details] [diff] [review]
Proposed Patch

sr=bienvenu - we still include mailOverlay.js, so you won't get any savings
there...
Attachment #108737 - Flags: superreview?(bienvenu) → superreview+

Comment 6

16 years ago
Comment on attachment 108737 [details] [diff] [review]
Proposed Patch

r=jag
Attachment #108737 - Flags: review?(jaggernaut) → review+
(Assignee)

Updated

16 years ago
Keywords: patch
(Reporter)

Comment 7

16 years ago
checked in
Assignee: naving → neil
(Assignee)

Comment 8

15 years ago
Oops, timeless checked this in ages ago :-)
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
(Reporter)

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
Duplicate of this bug: 171954
You need to log in before you can comment on or make changes to this bug.