If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tapping on a push notification fails to navigate to page on Android

RESOLVED FIXED

Status

()

Core
DOM: Push Notifications
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: droeh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Using the Push Clients Demo on serviceworke.rs[0], tap the "Send Notification" button and then navigate to another page. When the push notification arrives, tapping it should navigate back to the Push Clients Demo page, but instead does nothing. I'm fairly certain this worked a couple of weeks ago.

[0]: https://serviceworke.rs/push-clients_demo.html
Hmm, it looks like that demo uses `Client::focus`, which AFAIK we don't support on Android yet. If you close the tab, it'll call `openWindow` instead, but I don't think focusing an existing one will work.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1235431
(Reporter)

Comment 2

a year ago
That's not the same bug; currently even what worked before (eg having the service worker open a new tab if you have closed the tab before the notification arrives) is broken. From mozregression, the culprit appears to be bug 1304145.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

a year ago
...but it looks like Jim already fixed it with the changes he landed for bug 1305498.
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.