Intermittent bidi/numeral/persian-1.html,persian-2.html,persian-3.html,persian-4.html,persian-5.html | application timed out after 330 seconds with no output

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
a year ago
3 months ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

(Blocks: 1 bug, {intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell unknown])

(Reporter)

Description

a year ago
treeherder
Filed by: philringnalda [at] gmail.com

https://treeherder.mozilla.org/logviewer.html#?job_id=4217577&repo=autoland

https://archive.mozilla.org/pub/firefox/tinderbox-builds/autoland-win32-pgo/1475134221/autoland_win7_vm_gfx_test_pgo-reftest-no-accel-bm129-tests1-windows-build16.txt.gz

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://archive.mozilla.org/pub/firefox/tinderbox-builds/autoland-win32-pgo/1475134221/autoland_win7_vm_gfx_test_pgo-reftest-no-accel-bm129-tests1-windows-build16.txt.gz&only_show_unexpected=1
Summary: Intermittent REFTEST ERROR | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/bidi/numeral/persian-5.html | application timed out after 330 seconds with no output → Intermittent REFTEST ERROR | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/bidi/numeral/persian-4.html,persian-5.html | application timed out after 330 seconds with no output
Summary: Intermittent REFTEST ERROR | file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/bidi/numeral/persian-4.html,persian-5.html | application timed out after 330 seconds with no output → Intermittent bidi/numeral/persian-1.html,persian-2.html,persian-4.html,persian-5.html | application timed out after 330 seconds with no output
Duplicate of this bug: 1308768
Duplicate of this bug: 1311918
Summary: Intermittent bidi/numeral/persian-1.html,persian-2.html,persian-4.html,persian-5.html | application timed out after 330 seconds with no output → Intermittent bidi/numeral/persian-1.html,persian-2.html,persian-3.html,persian-4.html,persian-5.html | application timed out after 330 seconds with no output

Comment 3

a year ago
10 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 4
* mozilla-central: 3
* autoland: 2
* fx-team: 1

Platform breakdown:
* windows7-32-vm: 10

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2016-10-24&endday=2016-10-30&tree=all

Comment 4

a year ago
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 3
* mozilla-inbound: 1
* fx-team: 1

Platform breakdown:
* windows7-32-vm: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2016-10-31&endday=2016-11-06&tree=all

Comment 5

a year ago
5 failures in 694 pushes (0.007 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* mozilla-inbound: 2
* autoland: 2
* mozilla-central: 1

Platform breakdown:
* windows7-32-vm: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2016-11-28&endday=2016-12-04&tree=all

Comment 6

a year ago
7 failures in 289 pushes (0.024 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* mozilla-inbound: 5
* mozilla-central: 1
* autoland: 1

Platform breakdown:
* windows7-32-vm: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2016-12-05&endday=2016-12-11&tree=all

Comment 7

11 months ago
7 failures in 609 pushes (0.011 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* autoland: 4
* mozilla-inbound: 2
* mozilla-central: 1

Platform breakdown:
* windows7-32-vm: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2016-12-19&endday=2016-12-25&tree=all

Comment 8

10 months ago
6 failures in 722 pushes (0.008 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* mozilla-inbound: 4
* mozilla-central: 1
* autoland: 1

Platform breakdown:
* windows7-32-vm: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-01-09&endday=2017-01-15&tree=all

Comment 9

10 months ago
8 failures in 749 pushes (0.011 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* mozilla-central: 3
* mozilla-inbound: 2
* autoland: 2
* mozilla-aurora: 1

Platform breakdown:
* windows7-32-vm: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-01-23&endday=2017-01-29&tree=all

Comment 10

10 months ago
7 failures in 733 pushes (0.01 failures/push) were associated with this bug in the last 7 days.  

Repository breakdown:
* mozilla-aurora: 3
* mozilla-inbound: 2
* mozilla-central: 1
* autoland: 1

Platform breakdown:
* windows7-32-vm: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-01-30&endday=2017-02-05&tree=all

Comment 11

9 months ago
14 failures in 836 pushes (0.017 failures/push) were associated with this bug in the last 7 days.  
Repository breakdown:
* mozilla-inbound: 6
* mozilla-aurora: 3
* autoland: 3
* try: 1
* mozilla-central: 1

Platform breakdown:
* windows7-32-vm: 14

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-02-06&endday=2017-02-12&tree=all

Comment 12

9 months ago
11 failures in 812 pushes (0.014 failures/push) were associated with this bug in the last 7 days.  
Repository breakdown:
* try: 3
* mozilla-inbound: 3
* autoland: 3
* mozilla-aurora: 2

Platform breakdown:
* windows7-32-vm: 8
* windows7-32: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-02-20&endday=2017-02-26&tree=all

Comment 13

9 months ago
11 failures in 783 pushes (0.014 failures/push) were associated with this bug in the last 7 days.  
Repository breakdown:
* autoland: 4
* mozilla-inbound: 3
* mozilla-aurora: 2
* oak: 1
* mozilla-central: 1

Platform breakdown:
* windows7-32-vm: 11

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-02-27&endday=2017-03-05&tree=all
Blocks: 1345093

Comment 14

9 months ago
8 failures in 790 pushes (0.01 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* oak: 2
* mozilla-inbound: 2
* autoland: 2
* try: 1
* mozilla-beta: 1

Platform breakdown:
* windows7-32-vm: 7
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-03-06&endday=2017-03-12&tree=all

Comment 15

8 months ago
7 failures in 777 pushes (0.009 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 3
* mozilla-inbound: 2
* mozilla-beta: 1
* mozilla-aurora: 1

Platform breakdown:
* windows7-32-vm: 7

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-03-13&endday=2017-03-19&tree=all

Comment 16

8 months ago
15 failures in 898 pushes (0.017 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* try: 4
* mozilla-central: 4
* mozilla-inbound: 2
* mozilla-beta: 2
* autoland: 2
* mozilla-aurora: 1

Platform breakdown:
* windows7-32-vm: 13
* windows7-32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-03-20&endday=2017-03-26&tree=all

Comment 17

8 months ago
21 failures in 845 pushes (0.025 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-central: 6
* autoland: 6
* try: 3
* mozilla-inbound: 2
* mozilla-aurora: 2
* oak: 1
* mozilla-beta: 1

Platform breakdown:
* windows7-32-vm: 21

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-03-27&endday=2017-04-02&tree=all

Comment 18

8 months ago
20 failures in 867 pushes (0.023 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 7
* mozilla-central: 6
* mozilla-inbound: 4
* try: 1
* mozilla-beta: 1
* mozilla-aurora: 1

Platform breakdown:
* windows7-32-vm: 14
* windows7-32: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-04-03&endday=2017-04-09&tree=all
:masayuki - This is a long-shot but I wonder if you think these failures might be related to your change in bug 1304624? The earliest failure I see in Orange Factor is shortly after that change. Note that all failures are on Windows. If it doesn't seem likely, no worries - just thought I'd ask.
Flags: needinfo?(masayuki)
I don't think so because the patch for bug 1304624 changes how to compute the text length in editor. The value is exposed only to IME. So, it shouldn't cause timeout unless it causes infinite loop.

Looks like that they check alt-text rendering of <img>. I guess that the cause of this bug is, image loader isn't decided that there is no image in 330 seconds.
Flags: needinfo?(masayuki)
All failures are on *Windows 7* - this is just another of the many heads of bug 1300355, where gfx OOMs, and depending on where in what test that gives us a blank or partly blank test image or reference image, assertion, or hang. A patch can easily "cause" one test or another, related or unrelated, to become more or less common in any one of those failure modes, but that's just coincidence, shoving something into the line of fire or shoving it away and letting something else step into the part of the run where gfx is going to OOM.

Comment 22

7 months ago
39 failures in 894 pushes (0.044 failures/push) were associated with this bug in the last 7 days. 

This is the #39 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 15
* try: 12
* mozilla-inbound: 7
* mozilla-central: 5

Platform breakdown:
* windows7-32-vm: 22
* windows7-32: 17

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-04-10&endday=2017-04-16&tree=all
Thanks :philor, I completely missed that.
Whiteboard: [stockwell needswork]
Duplicate of this bug: 1353098

Comment 25

7 months ago
18 failures in 817 pushes (0.022 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 9
* autoland: 5
* try: 1
* mozilla-central: 1
* mozilla-beta: 1
* mozilla-aurora: 1

Platform breakdown:
* windows7-32-vm: 15
* windows7-32: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-04-17&endday=2017-04-23&tree=all
this picked up in frequency this week, if this is related to bug 1300355, then maybe we are running more test jobs this week than last week.

Comment 27

7 months ago
45 failures in 883 pushes (0.051 failures/push) were associated with this bug in the last 7 days. 

This is the #21 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 14
* mozilla-inbound: 11
* mozilla-central: 10
* try: 8
* oak: 2

Platform breakdown:
* windows7-32-vm: 29
* windows7-32: 16

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-04-24&endday=2017-04-30&tree=all

Comment 28

7 months ago
29 failures in 770 pushes (0.038 failures/push) were associated with this bug in the last 7 days. 

This is the #36 most frequent failure this week.  

Repository breakdown:
* mozilla-central: 8
* autoland: 7
* mozilla-beta: 5
* try: 4
* mozilla-inbound: 4
* mozilla-release: 1

Platform breakdown:
* windows7-32-vm: 24
* windows7-32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-05-01&endday=2017-05-07&tree=all
Whiteboard: [stockwell needswork] → [stockwell unknown]

Comment 29

6 months ago
15 failures in 879 pushes (0.017 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 7
* try: 5
* mozilla-central: 3

Platform breakdown:
* windows7-32-vm: 11
* windows7-32: 4

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-05-08&endday=2017-05-14&tree=all

Comment 30

6 months ago
15 failures in 777 pushes (0.019 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* try: 4
* mozilla-central: 3
* autoland: 3
* mozilla-inbound: 2
* mozilla-beta: 2
* oak: 1

Platform breakdown:
* windows7-32-vm: 10
* windows7-32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-05-15&endday=2017-05-21&tree=all

Comment 31

6 months ago
22 failures in 891 pushes (0.025 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 9
* mozilla-inbound: 6
* try: 4
* mozilla-central: 2
* mozilla-beta: 1

Platform breakdown:
* windows7-32-vm: 19
* windows7-32: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-05-22&endday=2017-05-28&tree=all

Comment 32

6 months ago
40 failures in 820 pushes (0.049 failures/push) were associated with this bug in the last 7 days. 

This is the #33 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 16
* mozilla-inbound: 13
* mozilla-central: 9
* try: 1
* graphics: 1

Platform breakdown:
* windows7-32-vm: 35
* windows7-32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-05-29&endday=2017-06-04&tree=all

Comment 33

5 months ago
46 failures in 864 pushes (0.053 failures/push) were associated with this bug in the last 7 days. 

This is the #30 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 19
* mozilla-inbound: 14
* try: 7
* mozilla-central: 5
* mozilla-beta: 1

Platform breakdown:
* windows7-32-vm: 33
* windows7-32: 12
* windows7-32-vm-devedition: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-06-05&endday=2017-06-11&tree=all

Comment 34

5 months ago
12 failures in 814 pushes (0.015 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 6
* mozilla-inbound: 4
* mozilla-central: 2

Platform breakdown:
* windows7-32-vm: 11
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-06-12&endday=2017-06-18&tree=all

Comment 35

5 months ago
12 failures in 892 pushes (0.013 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 4
* mozilla-central: 3
* mozilla-beta: 3
* autoland: 2

Platform breakdown:
* windows7-32-vm: 11
* windows7-32-vm-devedition: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-06-19&endday=2017-06-25&tree=all

Comment 36

5 months ago
28 failures in 718 pushes (0.039 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 14
* mozilla-inbound: 10
* try: 2
* mozilla-central: 2

Platform breakdown:
* windows7-32-vm: 28

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-06-26&endday=2017-07-02&tree=all

Comment 37

5 months ago
33 failures in 656 pushes (0.05 failures/push) were associated with this bug in the last 7 days.   

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 14
* mozilla-inbound: 12
* mozilla-central: 5
* try: 1
* oak: 1

Platform breakdown:
* windows7-32-vm: 33

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-07-03&endday=2017-07-09&tree=all

Comment 38

4 months ago
31 failures in 720 pushes (0.043 failures/push) were associated with this bug in the last 7 days. 

This is the #47 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* mozilla-inbound: 14
* autoland: 8
* mozilla-central: 4
* try: 2
* mozilla-beta: 2
* oak: 1

Platform breakdown:
* windows7-32-vm: 30
* windows7-32-vm-devedition: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-07-10&endday=2017-07-16&tree=all
:jet, this has cycles from very frequent to silent over the last 10 months- I see 2 weeks of high frequency failures, could you help find an expert in the Layout area to look into this?  These are failing on opt (not debug) and win7 only.
Flags: needinfo?(bugs)
Whiteboard: [stockwell unknown] → [stockwell needswork]

Comment 40

4 months ago
25 failures in 822 pushes (0.03 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* try: 8
* autoland: 7
* mozilla-inbound: 5
* mozilla-central: 5

Platform breakdown:
* windows7-32-vm: 25

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-07-17&endday=2017-07-23&tree=all

Comment 41

4 months ago
35 failures in 1008 pushes (0.035 failures/push) were associated with this bug in the last 7 days.   

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* mozilla-inbound: 18
* autoland: 9
* try: 5
* mozilla-central: 2
* mozilla-beta: 1

Platform breakdown:
* windows7-32-vm: 34
* windows7-32-vm-devedition: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1306365&startday=2017-07-24&endday=2017-07-30&tree=all
nothing here since July 26th, I believe this is resolved.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Flags: needinfo?(bugs)
Resolution: --- → WORKSFORME
Whiteboard: [stockwell needswork] → [stockwell unknown]
You need to log in before you can comment on or make changes to this bug.