Form submission not posting correct action

VERIFIED DUPLICATE of bug 128521

Status

()

Core
HTML: Form Submission
--
major
VERIFIED DUPLICATE of bug 128521
16 years ago
8 years ago

People

(Reporter: andres, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

This Login page has multiple forms in the source.  There is one for entering
Login information.  When I enter my userName and password and click "Log In." 
It posts an action from a form other than its own.  Specifically, it posts the
action from the first form on the page, the search form.

I checked the source in Mozilla and IE and it is the same.  The login form
should post to "https://chaseonlineplus.chase.com/m/l".  Unfortunately, in
Mozilla it posts instead to "http://search.chase.com/chase.vts".  Weird.

Reproducible: Always
Steps to Reproduce:
1. Go to "https://chaseonlineplus.chase.com/index.html"
2. Enter anything into the userName and password fields
3. Click "Log In"

Actual Results:  Mozilla takes you to "http://search.chase.com/chase.vts"

Expected Results:  Mozilla should post this form to
"https://chaseonlineplus.chase.com/m/l"

Here is the form:

<form name=lf method=post action=https://chaseonlineplus.chase.com/m/l
onSubmit=" SetCookie(YIC,'yc',1,1);this.js.value=1; return true">
<table border=0 cellspacing=0 cellpadding=0 width=300 align=center class=bxbgc>
<tr class=bxbdc>
<td rowspan=8 width=1><spacer type=block width=1></td>
<td width=20 height=1><spacer type=block width=20></td>
<td width=258><spacer type=block width=1></td>

<td width=20><spacer type=block width=20></td>
<td rowspan=8 width=1><spacer type=block width=1></td>
</tr>
<tr>
<td rowspan=6 width=20><spacer type=block width=1></td>
<td valign=top width=258 height=18><div
style='position:relative;top:-9;left:-10'><table border=0 cellspacing=0
cellpadding=0 class=bxbgc><tr><td class=dbl>&nbsp;Log On to Chase Online
Plus&nbsp;</td></tr></table></div></td>
<td rowspan=6 width=20><spacer type=block width=1></td>
</tr>
<tr><td>Chase Online Plus User Name:</td></tr>
<tr><td> <input name=login taborder=0 autocomplete=off class=ib></td></tr>
<tr><td>Password:</td></tr>
<tr><td><input type=password name=pass taborder=1 autocomplete=off
class=ib><input type=hidden name=js value=''> &nbsp;<input type=hidden
name=lsubmit value=1><input type=submit value=' Log In '> &nbsp;<a
href=/policy/security.html><img src=/i/lock.gif width=11 height=13
border=0></a></td></tr>

</form>

Comment 1

16 years ago
This is a dupe of bug #128521 via bug #130195.

Goto the page.
View->Page Source
Find "form"

Results: 4 <form> and 2 </form>

Evangelism of the site would be a good thing too.

*** This bug has been marked as a duplicate of 128521 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.