focus lost from content area after menu action

VERIFIED DUPLICATE of bug 8956

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 8956
19 years ago
19 years ago

People

(Reporter: buster, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
paste an image between characters in a text run.  the selection is not what
you'd expect, it's collapsed in the parent.  I'd expect the selection to
be collapsed to the point just after pasted content.
(Reporter)

Updated

19 years ago
Assignee: buster → hyatt
Component: Editor → XP Toolkit/Widgets
Summary: selection wrong after paste → focus lost from content area after menu action
(Reporter)

Comment 1

19 years ago
actually, selection is correct. the caret is just invisible until you put focus
back into the text area.  This is true of other menu items as well, like undo.
I think this is a general XPMenu problem.  This occurs in the browser as well,
like after a copy.  Try selecting some text in the browser, copy from the edit
menu, then try using the up/down arrows to scroll.  You can't until you manually
set focus back to the content area.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
*** This bug has been marked as a duplicate of 8956 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
verified in 9/15 build.
You need to log in before you can comment on or make changes to this bug.