Too many onmouseover events on IFRAME

RESOLVED FIXED

Status

()

Core
DOM: Events
P3
normal
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: Jochen Magnus, Assigned: joki (gone))

Tracking

({pp, testcase})

Trunk
x86
Linux
pp, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310
BuildID:    2002031008

No mouseout event is fired when the mouse pointer is leaving an iframe. This
behaviour happens only in 0.9.9, not in previous releases. 

Example: Move the mouse over the newsline "+++ HH:MM ..." on the URL 
http://rhein-zeitung.de/. The iframe grows but never shrinks after
the mouse pointer leaves it. 

This bug may be connected with bug #123700 which is valid for the linux release
0.9.9  to.


Reproducible: Always
Steps to Reproduce:
1. Move the mouse over the newsline "+++ HH:MM ..." on the URL 
http://rhein-zeitung.de/.
2. Wait until the iframe grows
3. Leave the iframe

Actual Results:  iframe does never close

Expected Results:  iframe has to close like in all prev. releases ;-)

Comment 1

16 years ago
This works on windows 98 build 2002-03-13-03-trunk
but fails on build 2002-03-13-09-trunk on Linux RedHat... Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

16 years ago
This bug still exists in 1.0 RC1 under Linux

jo

Comment 3

16 years ago
1) Worksforme RC2 Linux.
2) http://www.mozilla.org/xpfe/xulref/iframe.html - doesn't specify onmouseout
for iframe. Presented case catches onmouseout from a <div>, no <iframe> in the
page code had "onmouseout".
3) iframe's events catching is still buggy. See bug 131784
4) Frontpages of newspapers are really bad examples, they change daily so
creating a testcase from the original "troublemaker" page before it vanishes is
essential.
(Reporter)

Comment 4

16 years ago
Please take a look on 
   http://rhein-zeitung.de/on/02/05/22/mozillatest.html

This page does not have the work around the bug and is the test case

Sincerly

jo

Comment 5

16 years ago
Created attachment 85890 [details]
simplified testcase(?)

>Move the mouse over the newsline "+++ HH:MM ..." on the URL 

Which line do you mean? 
Letzte Ă„nderung: 22.05.2002 10:50 von IndexRobot
is the only one with HH:MM and there's no "+++" in the whole page.

There's just one IFRAME tag on this page:

<iframe
src="http://cgi.rhein-zeitung.de/adserver.fcg?path=home468&amp;anzahl=2&doc=/on/02/05/22/mozillatest.html"
width="760" height="60" scrolling="no" frameborder="0" border="0"
framespacing="0" marginwidth="0" marginheight="0" name="ad"
style="margin-bottom:-4px"></iframe>

and it has no "onmouseout" event attached to it.
The "src" target webpage of the iframe:

<body bgcolor='white'><table width='100%' cellpadding='0' cellspacing='0'
border='0'><tr>
<td><a
href="http://cgi.rhein-zeitung.de//adserver.fcg?cmd=CLICK&amp;url=http://www.ford-foerster.de&amp;anzeige=foerster0205_home2"
target="_blank"><img src="http://rhein-zeitung.de/anz/pics/foerster0205.gif"
width="468" height="60" alt='Ford Foerster' border=0></a></td>
<td><a
href="http://cgi.rhein-zeitung.de//adserver.fcg?cmd=CLICK&amp;url=http://www.rheinmassiv.de/start.asp&amp;anzeige=rheinmassiv"
target="_blank"><img src="http://rhein-zeitung.de/anz/pics/rheinmassiv.gif"
width="234" height="60" alt="Klick!" border=0></a></td>
</tr></table></body>

contains no onmouseout events either.

Do you really mean "iframe" and not "div"? Only divs and anchors have
"onmouseout in this page.

I've created a simplified testcase for the div that opens for me on the page.
(Reporter)

Comment 6

16 years ago
Sorry, the test page was moved into the archive. I have created a new and very
short test case. Same URL as before:   
http://rhein-zeitung.de/on/02/05/22/mozillatest.html

This page now contains only the iframe with the non-working onMouse-Events.

jo

Comment 7

16 years ago
worksforme build 2002052306 (win32 rc3)

imho, it would be easier to find the bug if anyone added a rhein-zeitung.de in
the summary

greetings, renke

Comment 8

16 years ago
works for me on build 2002-05-22-07-trunk on linux
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 9

16 years ago
I am sorry, it does not work for me. IT works on the news site, but the testcase
still fails.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

16 years ago
Priority: -- → P3

Updated

16 years ago
Created attachment 101011 [details]
frame content for testcase
Created attachment 101012 [details]
Testcase
Attachment #85890 - Attachment is obsolete: true
It seems that too many onmouseover events are generated on Linux, it works
fine on Windows 2000.

Bug occurs in 2002-09-27-08 trunk Linux
Bug does not occur in 2002-09-28-08 trunk Windows 2000
Severity: major → normal
Keywords: pp
Summary: No Mouseouts on IFRAME → Too many onmouseover events on IFRAME

Comment 13

15 years ago
This appears to be fixed for me with current (linux) nightly builds. (20030302
or later)  Can someone confirm please?
(Reporter)

Comment 14

15 years ago
Yes, I tested it with 

Mozilla 1.3b (20030210) and it works fine!

(test with Mozilla 1.2.1 (200211130) still failed)

Thanks

jo

Comment 15

15 years ago
Marking as FIXED
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.