Folder pane scrollbars flash on and off if number of folders matches height

VERIFIED DUPLICATE of bug 121583

Status

SeaMonkey
MailNews: Message Display
--
minor
VERIFIED DUPLICATE of bug 121583
16 years ago
13 years ago

People

(Reporter: Jani Patokallio, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310
BuildID:    20020301008

In MailNews, if folders are open so that their combined height exactly matches
the height of the window plus [0 > x > 1] (ie. one row is half-visible), both
horizontal and vertical scrollbars appear and disappear in an infinite loop.  

Reproducible: Sometimes
Steps to Reproduce:
I have one mail account and two news accounts, the problem
happened after I added the second news server and subscribed to
a few new groups.  News #1 was closed, mail #1 was open with
with 5 folders, news #2 was open with four.  The horizontal
scrollbar is not visible, and I'm using the preferences "type 1"
layout with combined folder pane and sidebar on the left.

The problem occurs as soon as the combined height of the nodes
in the folder tree "touches" the edge.  Adjusting the height of
the tree makes it disappear, readjusting to the touching height
makes it reappear.

However, if I drag the lower edge of the pane downward and make
the pane taller (or shorter), the problem goes away for good and can no longer
be repeated.  After I submit this I'll try restarting Mozilla and seeing if it
happens again...


Actual Results:  The vertical and horizontal scrollbar toggled on and off wildly.


Expected Results:  The vertical scrollbar should have appeared and stayed there;
the horizontal scrollbar should not have appeared.


This is purely a cosmetic bug but a spectacularly ugly one...

Comment 1

16 years ago
resolving as dup of bug 121583 (by way of bug 124530 -> bug 122153)

*** This bug has been marked as a duplicate of 121583 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: esther → olgam

Comment 2

16 years ago
Verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.