Closed Bug 1306640 Opened 4 years ago Closed 4 years ago

Remove some warnings in cairo

Categories

(Core :: Graphics, defect, P3)

51 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: Sylvestre, Assigned: Sylvestre)

References

Details

(Keywords: feature, Whiteboard: [gfx-noted])

Attachments

(1 file)

In order to limit the noise and enable more -Werror= and also because we basically forked cairo, I would like to fix some warnings in cairo.
Assignee: nobody → sledru
Attachment #8796587 - Flags: review?(jmuizelaar)
Attachment #8796587 - Flags: review?(lsalzman)
The idea is also to decrease the number of warnings.
Comment on attachment 8796587 [details]
Bug 1306640 - Silent a -Wunused-but-set-variable in cairo. We don't want to diverge too much from upstream

https://reviewboard.mozilla.org/r/82390/#review84504

Not exactly thrilled by this, but we've already given up on updating Cairo, so go ahead.
Attachment #8796587 - Flags: review?(lsalzman) → review+
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3d5379dbab72
Remove some warnings in cairo r=lsalzman
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a06e83406d1b
Backed out changeset 3d5379dbab72 for bustage on a CLOSED TREE
I think it would be better to just turn off these warnings for this code. I think there's still value in us not diverging needlessly.
Plus, now that we're using Skia for most performance critical areas I think it's reasonable for us to start thinking about replacing our fork with upstream.
(In reply to Jeff Muizelaar [:jrmuizel] from comment #8)
> I think it would be better to just turn off these warnings for this code. I
> think there's still value in us not diverging needlessly.

I suppose this might be saner, in that we don't expect to be doing significant development on our version of Cairo either, so it is very unlikely new regressions in it will be introduced by us. So there is not much danger in just turning off the warnings in the moz.build on Cairo.

So, I'm also open to that interpretation of things. I guess I am ambivalent on this, though, since either way, so long as we acknowledge beyond just cosmetic changes to tree Cairo or moz.build changes, we don't introduce any big semantic/feature changes.

But yet, probably just easier to disable the warnings there.
Keywords: feature
Priority: -- → P3
Whiteboard: [gfx-noted]
Flags: needinfo?(sledru)
Comment on attachment 8796587 [details]
Bug 1306640 - Silent a -Wunused-but-set-variable in cairo. We don't want to diverge too much from upstream

https://reviewboard.mozilla.org/r/82390/#review88104
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/64f564d7ea43
Silent a -Wunused-but-set-variable in cairo. We don't want to diverge too much from upstream r=lsalzman
https://hg.mozilla.org/mozilla-central/rev/64f564d7ea43
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Depends on: 1323923
You need to log in before you can comment on or make changes to this bug.