Inspector sidebar min-width too big in Firefox 51

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: Inspector
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: CristiComo, Assigned: gasolin)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8796607 [details]
Aurora compared to nightly.PNG

[Affected versions]:

 Fx 51.0a2 (20160930004005)

[Affected platforms]:

 OS X 10.10.5

[Steps to reproduce]:

 1. Start Nightly
 2. Open DevTools > Inspector
 3. Resize sidebar until displaying all-tabs-menu

[Expected result]:

 The Side bar is resized and the all-tabs-menu button id displayed.

[Actual result]:

 The resize is blocked after a while.

[Regression range]:

 Last good: 20160801004002
 First bad: 20160802004003

[Additional notes]:

 1.This issue occurred only on Max OS.
 2.In the attachment nightly has the intended behavior, aurora is resized at it's minimum.
(Reporter)

Updated

a year ago
Flags: needinfo?(odvarko)
@Fred, the all-tabs-menu isn't visible on Mac.
Could you please investigate this?

Honza
Flags: needinfo?(odvarko) → needinfo?(gasolin)
(Assignee)

Updated

a year ago
Assignee: nobody → gasolin
Flags: needinfo?(gasolin)
(Assignee)

Comment 2

a year ago
As I remembered before the new slider patch is landed(in nightly), there's a fixed minimum sidebar size on Mac. I downloaded released version(49) on Mac and seen the fixed minimum sidebar size is there as well.

Helen, as Cristian said if the fixed minimum sidebar size was a Mac only feature, should we re-implement that in the future version, for all platform, for mac only, or just let it go?
Flags: needinfo?(hholmes)
(In reply to Fred Lin [:gasolin] from comment #2)
> As I remembered before the new slider patch is landed(in nightly), there's a
> fixed minimum sidebar size on Mac. I downloaded released version(49) on Mac
> and seen the fixed minimum sidebar size is there as well.
> 
> Helen, as Cristian said if the fixed minimum sidebar size was a Mac only
> feature, should we re-implement that in the future version, for all
> platform, for mac only, or just let it go?

I think the question this bug is asking is, "Should the current implementation in Nightly be uplifted to all channels?" which I believe is yes. According to :jdescottes, the current implementation should be working in both Mac and Windows, which is the desired behavior.
Flags: needinfo?(hholmes)
First of all the behavior is identical on OSX/Windows/Linux. (pay attention to the theme you select though, as it modifies the size of the tabs).

Technically this bug is only about the min-width of the inspector sidebar. It changed during the last few releases. Quick recap of the different values we had:
- Nightly (v52):  50px (but still being finalized with open bugs as I write this)
- Aurora  (v51): 300px
- Beta    (v50): 300px
- Release (v49): 250px

In Firefox 50 we had a good reason to bump the min-width to 300px: there was no HTML replacement for the all-tabs menu. It landed only in 51, with Bug 1281789. In Firefox 51 we could have reduced that back to 250px but we didn't do it.

Note that in Nightly the inspector and splitter have been migrated from XUL to HTML and uplifting won't be straightforward. We need to decide if it's worth creating an aurora-only patch to reduce this min-width. I quickly tried reducing it to 50px on aurora and we run into the same kind of layout issues as on Nightly (Bug 1307408 for instance).

I personally don't think we should try to uplift what has been done on Nightly. You could reduce the min-width to 250px in an aurora-only since it's the value we had in v49.
OS: Mac OS X → All
Summary: Resize to inspector is limited on Mac → Inspector sidebar min-width too big in Firefox 51
Version: 41 Branch → 51 Branch
(Assignee)

Comment 5

a year ago
As julian said the slider's implementation is changed in nightly so we can't simply uplift the patch (to both Aurora & Beta). 

The INITIAL_SIDEBAR_SIZE is 350px, which is bigger than min sidebar width. With 300px min sidebar width the sidebar content layout looks identically as what we've designed without various layout problems addressed in bug 1307408.


I'd close this issue first. Please re-open it if you have good reason that we still should change the min sidebar width in Aurora & Beta.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.