Closed Bug 1306700 Opened 4 years ago Closed 4 years ago

Assertion failure: ret == Z_STREAM_END in js::DecompressStringChunk

Categories

(Core :: JavaScript Engine, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1306963
Tracking Status
firefox52 --- fixed

People

(Reporter: jchen, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-013bffdb-20ba-4742-aa45-ba3fe2160930.
=============================================================

Crash that started with the 9-29 Nightly and is currently the #3 top crash for that Nightly. Regression from bug 1305570 since the patch from that bug introduced the MOZ_RELEASE_ASSERT line.
Flags: needinfo?(jdemooij)
(In reply to Jim Chen [:jchen] [:darchons] from comment #0)
> Regression from bug 1305570 since the patch from that bug
> introduced the MOZ_RELEASE_ASSERT line.

Yes, that patch changed the MOZ_ASSERT to MOZ_RELEASE_ASSERT.

These crashes are interesting. There are not many URLs available, but I do see some Google search pages. I wonder if the compressed data got corrupted, or if there's a bug with ScriptSource ownership.

Later I will take a closer look at the crash dumps to see if the data on the stack makes sense. If we're lucky the return value from the inflate call is still available, but it likely got clobbered by the MOZ_RELEASE_ASSERT.
I get the crash with debug build.
ret value is -3.

https://dxr.mozilla.org/mozilla-central/rev/344920af45b92da6d4f5b84738e1c7a3fb582461/modules/zlib/src/zlib.h#178
> #define Z_DATA_ERROR   (-3)
Just landed bug 1306963, it should fix these crashes.
Depends on: 1306963
Crash volume for signature 'js::DecompressStringChunk':
 - nightly (version 52): 410 crashes from 2016-09-19.
 - aurora  (version 51): 0 crashes from 2016-09-19.
 - beta    (version 50): 0 crashes from 2016-09-20.
 - release (version 49): 0 crashes from 2016-09-05.
 - esr     (version 45): 0 crashes from 2016-06-01.

Crash volume on the last weeks (Week N is from 10-03 to 10-09):
            W. N-1  W. N-2
 - nightly     410       0
 - aurora        0       0
 - beta          0       0
 - release       0       0
 - esr           0       0

Affected platforms: Windows, Mac OS X, Linux

Crash rank on the last 7 days:
           Browser   Content     Plugin
 - nightly #3        #5
 - aurora
 - beta
 - release
 - esr
(In reply to Jan de Mooij [:jandem] from comment #4)
> Just landed bug 1306963, it should fix these crashes.

I don't see these crashes with the latest builds, so closing this.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(jdemooij)
Resolution: --- → DUPLICATE
Duplicate of bug: 1306963
You need to log in before you can comment on or make changes to this bug.