distortion of audio playback

RESOLVED DUPLICATE of bug 1305826

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1305826
2 years ago
2 years ago

People

(Reporter: nji9, Unassigned)

Tracking

49 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

Play-Button at allmusic.com


Actual results:

plays the sample, but distorted


Expected results:

plays correctly, as it does in v.48.0
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows XP
Hardware: Unspecified → x86

Updated

2 years ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Component: Audio/Video: Playback → Audio/Video: cubeb
Kinetik, Padenot - can one of you confirm if this is cubeb or some other cause (WebAudio, decoding, etc)?  Thanks
Flags: needinfo?(padenot)
Flags: needinfo?(kinetik)
Whiteboard: [needinfo 2016/10/05 to kinetik/padenot]
I can't see a play button on the main allmusic.com page, but if I visit a specific album (e.g. http://www.allmusic.com/album/l-ascenseur-pour-lechafaud-original-soundtrack-mw0000203518 linked from the front page under "Staff Picks") and play the sample of the first track, it sounds fine to me in both 48 and 49 on Windows 10 using both the WASAPI and WinMM audio backends, as well as on Linux.  I don't have an XP machine available to test on right now.

The site is asking to use Flash, but as far as I can tell it prefers using HTML5 media playback in any case.  The samples on the page I linked seem to be MP3s from a quick inspection of the page source.

Reporter, if you're able to test with a newer Windows (Vista+), do you hear the same problem?  Or with a later (Nightly) build of Firefox?  If you can be more explicit about which play button you're clicking, perhaps with a direct link, that'd be useful to ensure we're testing the same thing you are.
Flags: needinfo?(kinetik) → needinfo?(nji9)
(Reporter)

Comment 4

2 years ago
@ kinetik:
The effect is on every audio at allmusic, and also on the track you mentioned.
I'm not able to test at another operation system than mine (XP Pro SP3).
After experiencing this effect on firefox v.49.0.1. I re-installed v.48.0 and everything was fine with it. Then updated to 49.0.1. again and the distortion was there again.
The effect is shown in the whole 30s sample.
At the end of the 30s, the visual progress stops short before the end while the sound plays 2 more seconds.
The effect is the same when I play the sample again (= no cache problem).
Flags: needinfo?(nji9)
Thanks.  Would you mind testing a more recent build such as a Beta, Aurora, or Nightly?  That'd answer Jean-Yves' question in comment 3.
Flags: needinfo?(nji9)
(Reporter)

Comment 6

2 years ago
Tested v.50.0b4 - no error there.
Flags: needinfo?(nji9)
Thanks for testing and confirming.  I'll mark this as a duplicate of that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1305826
Component: Audio/Video: cubeb → Audio/Video: Playback
Flags: needinfo?(padenot)
Whiteboard: [needinfo 2016/10/05 to kinetik/padenot]
(Reporter)

Comment 8

2 years ago
Sorry for entering a dupe.
When I entered the bug there was no suggestion on the former entered.
You need to log in before you can comment on or make changes to this bug.