Closed Bug 1306722 Opened 3 years ago Closed 3 years ago

Make l10n nightly builds in builds-4hr use 40 character SHA revision

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(firefox51 fixed, firefox52 fixed)

RESOLVED FIXED
Tracking Status
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: emorley, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Searching builds-4hr for jobs using the legacy revision format found:
https://bug1306707.bmoattachments.org/attachment.cgi?id=8796694

Treeherder would like to soon drop support for 12 character SHAs, so it would be helpful if l10n nightlies were switched to them.

Justin, could you help?

Thanks :-)
Flags: needinfo?(bugspam.Callek)
I'm not sure how to process this atm. (nor how to easily prioritize) -- whats your timeline for the obsolescence of this codepath?

(as in, at what point will these 12-char SHAs no longer appear on treeherder)
Flags: needinfo?(bugspam.Callek) → needinfo?(emorley)
Ideally within the next month or two :-)
Flags: needinfo?(emorley)
(In reply to Nick Thomas [:nthomas] from comment #3)
> Probably caused by
> https://dxr.mozilla.org/mozilla-central/rev/
> d26ac63f1b81c3fce35448a7c502e95e0b5c56c0/testing/mozharness/mozharness/
> mozilla/building/buildbase.py#1202

Will, don't suppose you have a mozilla-central checkout around and set up with reviewboard etc? If so, would you mind making the one line change here? :-)
Flags: needinfo?(wlachance)
(In reply to Nick Thomas [:nthomas] from comment #3)
> Probably caused by
> https://dxr.mozilla.org/mozilla-central/rev/
> d26ac63f1b81c3fce35448a7c502e95e0b5c56c0/testing/mozharness/mozharness/
> mozilla/building/buildbase.py#1202

I'm less sure about this, but should be a safe/easy fix, I'll patch this up...
Flags: needinfo?(wlachance)
Comment on attachment 8808716 [details]
Bug 1306722 - Make l10n nightly builds in builds-4hr use 40 character SHA revision.

https://reviewboard.mozilla.org/r/91464/#review91380
Attachment #8808716 - Flags: review?(nthomas) → review+
Pushed by Callek@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5a0c37ab1352
Make l10n nightly builds in builds-4hr use 40 character SHA revision. r=nthomas
https://hg.mozilla.org/mozilla-central/rev/5a0c37ab1352
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Tomcat, I don't suppose you could do a massive favour and backport this to aurora too? :-)
Flags: needinfo?(cbook)
Many thanks Tomcat!
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.