Closed Bug 1306733 Opened 4 years ago Closed 4 years ago

Crash in @0x0 | nsTimerEvent::Run

Categories

(Core :: XPCOM, defect)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox51 --- wontfix
firefox52 --- fixed
firefox53 --- fixed
firefox54 --- fixed

People

(Reporter: jchen, Assigned: bwc)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-da4f6534-a979-434e-8b80-6a9572160930.
=============================================================

Low volume crash that started with the 9-29 Nightly. So far it's the #19 top crash for that Nightly with 8 crashes.

Byron, since this crash appeared right after bug 1157323 landed, do you think this is a regression from that bug?
Flags: needinfo?(docfaraday)
I think that bug 1157323 has uncovered some pre-existing problem here. But, I'm not seeing the smoking gun. Let me try a fix.
Assignee: nobody → docfaraday
Flags: needinfo?(docfaraday)
Attachment #8796730 - Flags: review?(nfroyd)
Comment on attachment 8796730 [details]
Bug 1306733: Don't crash on release builds if mTimer isn't set here.

https://reviewboard.mozilla.org/r/82478/#review81760

We're going to need to uplift this, correct?
Attachment #8796730 - Flags: review?(nfroyd) → review+
No, that rewrite landed in 52.
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/067c15e2620f
Don't crash on release builds if mTimer isn't set here. r=froydnj
https://hg.mozilla.org/mozilla-central/rev/067c15e2620f
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Patch does not seem to have helped. Stack must be misleading somehow. Investigating further.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This might just be a dupe of bug 1307688, actually.
This is the #7 top crash in Nightly 20161216030207. It's occurred 111 times in the past 7 days, on both Nightly 53 and Aurora 52.

Byron, any more ideas?
Flags: needinfo?(docfaraday)
It could simply be that bug 1285384 and/or bug 1290894 is causing this. I had started investigating a workaround, but got swamped by other stuff.
Flags: needinfo?(docfaraday)
Depends on: 1328643
Crash volume for signature '@0x0 | nsTimerEvent::Run':
 - nightly (version 54): 147 crashes from 2017-01-23.
 - aurora  (version 53): 149 crashes from 2017-01-23.
 - beta    (version 52): 2613 crashes from 2017-01-23.
 - release (version 51): 3 crashes from 2017-01-16.
 - esr     (version 45): 0 crashes from 2016-08-10.

Crash volume on the last weeks (Week N is from 02-06 to 02-12):
            W. N-1  W. N-2  W. N-3  W. N-4  W. N-5  W. N-6  W. N-7
 - nightly      75      64
 - aurora      102       6
 - beta       1714       0
 - release       1       1       0
 - esr           0       0       0       0       0       0       0

Affected platform: Windows

Crash rank on the last 7 days:
           Browser   Content   Plugin
 - nightly #234      #17
 - aurora  #90       #6
 - beta    #30       #4
 - release
 - esr
See Also: → 1323804
Looking at the build ids, it would appear that the landing of bug 1328643 fixed this.
The uplift of bug 1328643 to aurora has stopped this crash there also. No crashes on b5 either.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.