Intermittent devtools/client/responsive.html/test/browser/browser_device_change.js | UA should be set to Mozilla/5.0 (Windows NT 6.1; rv:52.0) Gecko/20100101 Firefox/52.0 - Got Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0, expected Mozilla/5.0...

RESOLVED FIXED in Firefox 52

Status

defect
P1
normal
RESOLVED FIXED
3 years ago
Last year

People

(Reporter: intermittent-bug-filer, Assigned: jryans)

Tracking

({intermittent-failure})

unspecified
Firefox 52
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox50 unaffected, firefox51 disabled, firefox52 fixed)

Details

(Whiteboard: [multiviewport] [reserve-rdm])

Attachments

(1 attachment)

Started right after bug 1302879 landed.
Blocks: 1302879
Flags: needinfo?(zer0)
Whiteboard: [multiviewport] [triage]
That probably happens because bug 1302879, before the fix, prevents the unit test to continue to that point. However, I had a similar issues (with ddpx instead of UA) that the patch of bug 1303484 fixed.
So let's check again this after the patch is landed.
Flags: needinfo?(zer0)
Flags: qe-verify-
Priority: -- → P3
Whiteboard: [multiviewport] [triage] → [multiviewport] [reserve-rdm]
It seems like this is still happening even after bug 1303484 landed.  :zer0, would you be able to take a look?
Flags: needinfo?(zer0)
Assignee: nobody → zer0
Status: NEW → ASSIGNED
Iteration: --- → 52.2 - Oct 17
Priority: P3 → P1
(In reply to Ryan VanderMeulen [:RyanVM] from comment #1)
> Started right after bug 1302879 landed.

...which was also uplifted to 51...
Iteration: 52.2 - Oct 17 → 52.3 - Nov 7
I am able to reproduce this locally.  :zer0 said via email that he hasn't looked into this yet, so I'll take it over.
Assignee: zer0 → jryans
Flags: needinfo?(zer0)
Comment on attachment 8804663 [details]
Bug 1306816 - Fix intermittent failure in RDM device change test.

https://reviewboard.mozilla.org/r/88568/#review87750
Attachment #8804663 - Flags: review?(gl) → review+
Pushed by jryans@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/082d0ffb918f
Fix intermittent failure in RDM device change test. r=gl
https://hg.mozilla.org/mozilla-central/rev/082d0ffb918f
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Please request Aurora approval on this when you get a chance. Also, looks like it'll need a bit of rebasing.
Flags: needinfo?(jryans)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #24)
> Please request Aurora approval on this when you get a chance. Also, looks
> like it'll need a bit of rebasing.

Since this feature is disabled by default in Aurora, I think disabling the test in Aurora is the most expedient path.  I'll do this now.
Flags: needinfo?(jryans)
No longer blocks: 1440678
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.