Stylesheet First Object doesn't work on LINKed stylesheets

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Laird Bedore, Assigned: dbaron)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
There appears to be a parsing bug that causes the first object in a linked
stylesheet to go ignored. It seems like simply including a {} bracket pair
before the first object is adequate to make mozilla behave properly.

I've noticed this bug since M13 (when I started regularly using mozilla), but
haven't been motivated to track it down until now.

Please see the URLs http://www.vectorstar.net/mozilla/broken.html and
http://www.vectorstar.net/mozilla/works.html for live examples.
(Assignee)

Comment 1

16 years ago
<style type="text/css"> is not supposed to be part of an external stylesheet --
that's HTML, not CSS.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
text/css is CSS, not HTML. You don't need to (and in fact are not allowed to)
put any HTML in text/css files.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.