[PATCH][PARTIAL]Crash when changing scale while Printing

VERIFIED FIXED in mozilla1.0

Status

()

Core
Print Preview
P1
critical
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: rods (gone), Assigned: rods (gone))

Tracking

({crash})

Trunk
mozilla1.0
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment)

1.07 KB, patch
kinmoz
: review+
Marc Attinasi
: superreview+
jesup
: approval+
Details | Diff | Splinter Review
(Assignee)

Description

16 years ago
 
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Keywords: crash, nsbeta1
Target Milestone: --- → mozilla1.0

Comment 1

16 years ago
nsbeta1+. 
Severity: normal → critical
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P1
(Assignee)

Comment 2

16 years ago
Created attachment 73942 [details] [diff] [review]
patch

Although the front-end should be disabled and not allow the user to make any
changes to PP while the document is printing. This samll fix is back-end
insurance to keep a crash from happening.
(Assignee)

Updated

16 years ago
Summary: Crash when changing scale while Printing → [FIX][PARTIAL]Crash when changing scale while Printing

Comment 3

16 years ago
Mine.  Nominating for nav triage to look at since this bug was nsbeta1+ by the
backend team.  

The work will take a couple of days and the risk is low since it can probably
only makes things better, not worse: we will only be adding a progress listener
to print.  We'll disable the UI while printing and reenable it when the progress
listener indicates the print job has been sent of or has failed.  

If only the backend patch is checked in I believe this is not too heinous a bug
at this point in the release schedule.
Assignee: rods → sgehani
Status: ASSIGNED → NEW
Keywords: nsbeta1+ → nsbeta1

Comment 4

16 years ago
steps to reproduce?

Comment 5

16 years ago
Here's what I did on a Win2K trunk mozilla build dated 2002032803:

(1) Print previewed http://slashdot.org (roughly 6 pages long).
(2) Clicked the ``Print...'' button from the print preview toolbar.
(3) Clicked the ``Print'' button on the print dialog that popped up.
(4) Start scaling the page down while the print progress dialog was still up.
(5) I saw an alert that said: ``Printing failed for some reason.''  
(6) When I dismissed the alert by clicking the ``OK'' button I crashed.

I still think this will affect a limited audience since folks don't tend to
scale once they have sent a document for printing.

Rod, 
Please confirm or modify my steps.  Thanks.

Comment 6

16 years ago
Is the backend patch already checked in?  Why would we want to spend two more
days on this if it already prevents a crash?

Comment 7

16 years ago
nsbeta1+ per Nav triage team, adt3. Please just checkin the backend patch, not
worth 2 days of Samir's time to do the 'right' fix.
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt3]

Comment 8

16 years ago
-> rods to checkin the backend patch
Assignee: sgehani → rods

Updated

16 years ago
Summary: [FIX][PARTIAL]Crash when changing scale while Printing → [PATCH][PARTIAL]Crash when changing scale while Printing
[adt2] crash during printing.
Whiteboard: [adt3] → [adt2]
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Keywords: review

Comment 10

16 years ago
Comment on attachment 73942 [details] [diff] [review]
patch

Good safety checks - sr=attinasi
Attachment #73942 - Flags: superreview+
adt1.0.0
Keywords: adt1.0.0, approval

Comment 13

16 years ago
adt1.0.0+ (on ADT's behalf) approval for checkin into 1.0.
Keywords: adt1.0.0 → adt1.0.0+
(Assignee)

Comment 15

16 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 16

16 years ago
verified in 4/10 build.
Status: RESOLVED → VERIFIED

Updated

16 years ago
Keywords: fixed1.0.0

Comment 17

16 years ago
was this checked in on the branch? (see bug 137902)

Comment 18

16 years ago
based on the date this was resolved it landed before the branch was cut. 
You need to log in before you can comment on or make changes to this bug.