<img> tag missing from HTML Element reference docs

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: gilbertson.david, Unassigned)

Tracking

({in-triage})

Details

(Whiteboard: [specification][type:bug], URL)

(Reporter)

Description

2 years ago
What did you do?
================
Read the docs on this page: https://developer.mozilla.org/en-US/docs/Web/HTML/Element

What happened?
==============
I didn't see <img> in the list

What should have happened?
==========================
I should have seen <img> in the list, probably under "embedded content"

Is there anything else we should know?
======================================
I agree, and a staff writer will probably agree at our meeting in the morning. It is a wiki, and you could create an account and get credit for improving the page.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

2 years ago
I was planning on making the change myself (I'm all about the credit :)), but I don't see the table on the edit page, just this:

{{HTMLRefTable({"include":["HTML embedded content"], "exclude":["multimedia"]})}}

which was a bit beyond me. Is that something I can find and change?

On a related note, <picture> is missing too. Oh and <content> and <element> can probably go from the web components section.
Sorry, I didn't look at the page source. You are right, it makes heavy use of a KumaScript template to do the work:

https://developer.mozilla.org/en-US/docs/Template:HTMLRefTable

I think the "Image and Multimedia" is probably the right section, with the tag "multimedia":

https://developer.mozilla.org/en-US/docs/Web/HTML/Element#Image_and_multimedia

The issue appears to be that <img> has the tags "HTML", "embedded", and "content", but not the multi-word tag "HTML embedded content", so it is not cached by the macro.  Once the correct tag is added, a force-refresh should add <img> to the HTML/Element page

Thanks for bringing this up. There are probably a few other pages in the same situation.
Component: Wiki pages → HTML
Keywords: in-triage
Product: Mozilla Developer Network → Developer Documentation
Fixed. The problem was indeed tagging; <img> didn't have the "Multimedia" tag on it. Now it does, and it shows up in the "Image and multimedia" section.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.