If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

test_bug1295852.html is going to fail when Gecko 51 merges to beta November 7th

RESOLVED DUPLICATE of bug 1304814

Status

()

Core
General
RESOLVED DUPLICATE of bug 1304814
a year ago
a year ago

People

(Reporter: philor, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(firefox49 unaffected, firefox-esr45 unaffected, firefox50 unaffected, firefox51 affected, firefox52 affected)

Details

(Reporter)

Description

a year ago
https://dxr.mozilla.org/mozilla-aurora/source/modules/libpref/init/all.js#2693 - animation isn't shipping yet, you have to set it if you use it in a test.

https://treeherder.mozilla.org/logviewer.html#?job_id=28370159&repo=try

 [task 2016-10-02T05:05:00.424181Z] 05:05:00     INFO -  156 INFO TEST-START | dom/base/test/test_bug1295852.html
 [task 2016-10-02T05:05:00.686836Z] 05:05:00     INFO -  ++DOMWINDOW == 144 (0x7ff221165c00) [pid = 1603] [serial = 452] [outer = 0x7ff21302a000]
 [task 2016-10-02T05:05:02.470300Z] 05:05:02     INFO -  157 INFO TEST-UNEXPECTED-FAIL | dom/base/test/test_bug1295852.html | uncaught exception - TypeError: element.getAnimations is not a function at @http://mochi.test:8888/tests/dom/base/test/test_bug1295852.html:16:6
 [task 2016-10-02T05:05:02.470616Z] 05:05:02     INFO -  @http://mochi.test:8888/tests/dom/base/test/test_bug1295852.html:13:1
 [task 2016-10-02T05:05:02.472062Z] 05:05:02     INFO -      simpletestOnerror@SimpleTest/SimpleTest.js:1582:11
 [task 2016-10-02T05:05:02.476449Z] 05:05:02     INFO -  JavaScript error: http://mochi.test:8888/tests/dom/base/test/test_bug1295852.html, line 16: TypeError: element.getAnimations is not a function
(Reporter)

Updated

a year ago
status-firefox49: --- → unaffected
status-firefox50: --- → unaffected
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox-esr45: --- → unaffected
Flags: needinfo?(cam)
Oh, I should just uplift bug 1304814.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(cam)
Resolution: --- → DUPLICATE
Duplicate of bug: 1304814
(Reporter)

Comment 2

a year ago
Heh, been a long time since I last got undercut by a central-as-beta try :)
You need to log in before you can comment on or make changes to this bug.