Canvas pattern no-repeat has pixel smudging

RESOLVED DUPLICATE of bug 1263776

Status

()

Core
Canvas: 2D
RESOLVED DUPLICATE of bug 1263776
a year ago
a year ago

People

(Reporter: andreabogazzi79, Unassigned)

Tracking

({correctness})

49 Branch
correctness
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8796926 [details]
Screen Shot 2016-10-02 at 10.22.00 AM.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36

Steps to reproduce:

Trying to fill an area with a non repeating pattern and a transformation ( translate or rotate ).

http://jsfiddle.net/emeagcnx/22/

The bug is here at least since december 2015, but i think earlier.


Actual results:

the pattern has pixel smudging in the transformation area


Expected results:

the pattern should not have this pixel trail behind
Chrome has same bug
Ie, Edge, safari can render it correctly.

Comment 1

a year ago
@reporter

Could you attach results of about:support (Help > Troubleshooting Information)?
Flags: needinfo?(andreabogazzi79)
(Reporter)

Comment 2

a year ago
Application Basics
------------------

Name: Firefox
Version: 49.0
Build ID: 20160916101415
Update Channel: release
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:49.0) Gecko/20100101 Firefox/49.0
OS: Darwin 15.5.0
Multiprocess Windows: 1/1 (Enabled by default)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Multi-process staged rollout
Version: 1.3
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0.4
Enabled: true
ID: firefox@getpocket.com

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Graphics
--------

Features
Compositing: OpenGL
Asynchronous Pan/Zoom: wheel input enabled
WebGL Renderer: ATI Technologies Inc. -- AMD Radeon R9 M370X OpenGL Engine
Hardware H264 Decoding: Yes
GPU #1
Active: Yes
Vendor ID: 0x8086
Device ID: 0x0d26

Diagnostics
AzureCanvasAccelerated: 1
AzureCanvasBackend: skia
AzureContentBackend: skia
AzureFallbackCanvasBackend: none





Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.hashstats_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 1
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 8
browser.sessionstore.upgradeBackup.latestBuildID: 20160916101415
browser.startup.homepage_override.buildID: 20160916101415
browser.startup.homepage_override.mstone: 49.0
browser.tabs.remote.autostart.2: true
browser.urlbar.daysBeforeHidingSuggestionsPrompt: 0
browser.urlbar.lastSuggestionsPromptDate: 20160911
dom.apps.lastUpdate.buildID: 20160916101415
dom.apps.lastUpdate.mstone: 49.0
dom.apps.reset-permissions: true
dom.max_script_run_time: 0
dom.mozApps.used: true
extensions.lastAppVersion: 49.0
font.internaluseonly.changed: true
gfx.blacklist.direct2d.failureid: FEATURE_FAILURE_DL_BLACKLIST_g984
gfx.blacklist.layers.direct3d9.failureid: FEATURE_FAILURE_DL_BLACKLIST_g150
media.benchmark.vp9.fps: 212
media.benchmark.vp9.versioncheck: 1
media.gmp-gmpopenh264.abi: x86_64-gcc3-u-i386-x86_64
media.gmp-gmpopenh264.lastUpdate: 1471514836
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20160916101415
media.gmp-manager.lastCheck: 1475395484
media.gmp-widevinecdm.abi: x86_64-gcc3-u-i386-x86_64
media.gmp-widevinecdm.lastUpdate: 1474811583
media.gmp-widevinecdm.version: 1.4.8.903
media.gmp.storage.version.observed: 1
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1475004128
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1473323293

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.12
Version in use: 4.12

NSS
Expected minimum version: 3.25
Version in use: 3.25

NSSSMIME
Expected minimum version: 3.25
Version in use: 3.25

NSSSSL
Expected minimum version: 3.25
Version in use: 3.25

NSSUTIL
Expected minimum version: 3.25
Version in use: 3.25

Experimental Features
---------------------
sounds like a dupe of bug 1302718 and/or bug 1263776.

but the testcase doesn't match the bug summary.
it uses repeat-y instead of no-repeat, and looks like it's hitting different issue.
See Also: → bug 1302718
(Reporter)

Comment 4

a year ago
You can switch in the fiddle both 'no-repeat', 'repeat-x', 'repeat-y' and get the smudging in the non repeating side.

Yes sound similar, in my test case the bleeding is more evident.
(Reporter)

Updated

a year ago
Flags: needinfo?(andreabogazzi79)
Status: UNCONFIRMED → NEW
Component: Untriaged → Canvas: 2D
Ever confirmed: true
Product: Firefox → Core
This does indeed look like a duplicate of those.
Status: NEW → RESOLVED
Last Resolved: a year ago
Keywords: correctness
Resolution: --- → DUPLICATE
Whiteboard: [gfx-noted]
Duplicate of bug: 1263776
You need to log in before you can comment on or make changes to this bug.