images sometimes appear black [regression]

RESOLVED DUPLICATE of bug 1380649

Status

()

Core
ImageLib
P3
normal
RESOLVED DUPLICATE of bug 1380649
a year ago
2 months ago

People

(Reporter: Clemens Eisserer, Unassigned)

Tracking

({regression, regressionwindow-wanted})

50 Branch
Unspecified
Android
regression, regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(3 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160929120120
Firefox for Android

Steps to reproduce:

When browsing the web with FF 50b1 on Android (Nexus 5x), somtimes images appear black and stay that way until the page is reloaded (looks like a texture upload problem).

This seems to be a regression, as I haven't experienced it wiith earlier FF builds (pre 50-beta) and I didn't change settings or the FW of my device.
(Reporter)

Updated

a year ago
OS: Unspecified → Android
(Reporter)

Comment 1

a year ago
Created attachment 8796949 [details]
youtube
(Reporter)

Comment 2

a year ago
Created attachment 8796952 [details]
another website showing the issue
(Reporter)

Comment 3

a year ago
forgot to mention: although the screenshots show all images as black, sometimes only a few images are black while all the others are loaded correctly.

The issue can't be reproduced reliable - on my device it happens about once in 15-60min browsing time and various websites, so the issue doesn't seem to be dependent on the content.

Comment 4

a year ago
Hey Clemens 
Is this still happening  on the second 50 Beta?
Component: Untriaged → Graphics, Panning and Zooming
Product: Firefox → Firefox for Android

Updated

a year ago
Flags: needinfo?(linuxhippy)
Component: Graphics, Panning and Zooming → ImageLib
Product: Firefox for Android → Core
See Also: → bug 1290907
See Also: → bug 1292290
Keywords: regression
Priority: -- → P3
Whiteboard: [gfx-noted]
(Reporter)

Comment 5

a year ago
sure 50b4 is also affected
(Reporter)

Updated

a year ago
Flags: needinfo?(linuxhippy)
(Reporter)

Comment 6

a year ago
images seem alsoto disapear when zooming in/out:  https://youtu.be/SGkpUKegwfk

Comment 7

a year ago
Created attachment 8801560 [details]
Similar (or same) issue on OS X

I'm pretty sure I'm hitting this same issue on my mac (5K iMac running Sierra), every so often when switching tabs or windows I end up with some missing images.

It also leads to repainting issues, hovering over the results on Google shows the info bar that sometimes isn't cleared properly (And can end up painted multiple times getting progressively darker)
Keywords: regressionwindow-wanted
If anyone can find reliable steps to reproduce, or can reproduce reliably enough to bisect this that would be very helpful.
(Reporter)

Comment 9

a year ago
at last on android I experienced the issue from time to time when switching tabs and/or bringing firefox to foreground - so maybe it is some timing related issue which can not reproduced reliably.

However, I am quite sure it is a regression introduced recently, I've never experienced this issue with FF-48 (not 100% sure about 49).
(Reporter)

Comment 10

a year ago
I am not sure if this bug is somehow related to an issue I see on my linux desktop with OpenGL enabled - it also only shows up from time to time: bug 1306974

It started to appear at about the same time as this issue on Android, so maybe the opengl pipeline has been broken in the not-so-distant-past. Maybe it would make sense to take a look at the opengl related commits in the mentioned time-frame (firefox 48-50), as normal bisecting would be very cumbersome due to the sporadic nature of this bug.
(Reporter)

Comment 11

a year ago
just experienced this issue on a Snapdragon-410 powered low-end phone running Android-4.4.4
Andrew, can you reproduce this?
Flags: needinfo?(aosmond)

Comment 13

11 months ago
I haven't found a surefire way to reproduce this on Android, either, however I've noticed that when it occurs:
- Just zooming the page around doesn't fix it - the affected images remain black
- Neither does switching to a different tab and back again
- However momentarily sending Firefox into the background (if necessary followed by zooming the page around to trigger a repaint) *does* fix it
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 14

10 months ago
(In reply to Jan Henning [:JanH] from comment #13)
> I haven't found a surefire way to reproduce this on Android, either, however
> I've noticed that when it occurs:
> - Just zooming the page around doesn't fix it - the affected images remain
> black

After I've encountered it again, I have to correct myself: it doesn't immediately fix it. The images might appear when zooming in and then turn black again after zooming back out to the original zoom level, however after repeatedly changing the zoom level and scrolling around, the black images eventually disappeared again.
(Reporter)

Comment 15

10 months ago
finally cought this on cam - Nexus 5x, Android 7.1.1 (1.2017 update): https://youtu.be/eDgRs7KgZWo
Is it reproducible on the same page at all after restarting?
(Reporter)

Comment 17

10 months ago
no of course not reproducible - it some timing issue or race condition somewhere.
As can be seen the same page is rendered correctly after clicking a ling and using "back" to get back to the problematic page again.

otherwise i guess it would have been fixed a long time ago.
The video reminds me strongly of bug 1292290. The result of that bug was backing out the regression patch, it wasn't obvious why the patch had caused that, and no one ever investigated why it caused the bug. So it's quite possible that the same underlying bug still exists. So one point of attack (since bug 1292290 was reproducible) would be to investigate bug 1292290 to understand it's full cause.

Updated

5 months ago
Duplicate of this bug: 1375878

Comment 20

2 months ago
FWIW I see this on a daily basis on my n5x viewing mobile.twitter.com.

Comment 21

2 months ago
In case it gives somebody a clue, the relevant bit about momentarily backgrounding Firefox is probably that this triggers a heap minimisation (https://dxr.mozilla.org/mozilla-central/rev/ffe6cc09ccf38cca6f0e727837bbc6cb722d1e71/widget/android/nsAppShell.cpp#185). Going to about:memory and pressing "Minimize memory usage" also has the same effect and restores image rendering back to normal.

Comment 22

2 months ago
FWIW, I trigger this without backgrounding.  Typically it happens when I click a link in twitter and then go back to my twitter feed.  The previously viewable images are all black.
The upcoming nightly should contain the fix. Please reopen this bug if it continues to happen after build >= 20170919220202.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Flags: needinfo?(aosmond)
Resolution: --- → DUPLICATE
Duplicate of bug: 1380649

Comment 24

2 months ago
Glad to hear a possible solution has been found, thanks very much.

(In reply to Ben Kelly [:bkelly] from comment #22)
> FWIW, I trigger this without backgrounding.

No, what I meant is that once this bug happens, triggering a heap minimisation (either via backgrounding, or about:memory) restores image rendering back to normal.
You need to log in before you can comment on or make changes to this bug.