Firefox Sync does not backup bookmarks anymore

RESOLVED DUPLICATE of bug 1306950

Status

()

RESOLVED DUPLICATE of bug 1306950
2 years ago
2 years ago

People

(Reporter: davidbourguignon.net, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

I bookmarked links, synched then closed Firefox and opened it under a brand new profile.


Actual results:

After connecting Firefox, my new links were not synched at all under the new profile (the old ones were fine).


Expected results:

Sync means synchronization, therefore a few more bookmarks should be OK.

I guess this has to do with plenty of issues I encountered recently (see bug 1306950).

Updated

2 years ago
QA Whiteboard: [bugday-20161003]
Component: Untriaged → Sync
Hi! Sorry you're having issues. A few questions:

* How long are you waiting between starting Firefox and bookmarking, and between bookmarking and closing? There's a known class of bugs where we'll miss changes for 10 seconds after starting the browser, or if you quit before Firefox has a chance to finish syncing. Work for both bugs is in progress, but it sounds like this isn't your issue.

* Do you see any errors for recent sync logs in about:sync-log?

* Does bug 1306950 come up every time you restart Firefox? Does your account remain connected, even though other settings are reset? Sync generally gets confused when a profile is restored like that, but I'm wondering if something else is at play here.
Flags: needinfo?(contact)
(Reporter)

Comment 2

2 years ago
Hi Kit, thanks a lot for your feedback! I answer to your questions below.

* I have been waiting for a very long time before considering there was an issue with synch. I have even clicked on the synch button to make sure it gets triggered.

* Yes, several logs have been registered in the past few days...

* This is puzzling. It was not showing up every time yesterday, and today it seems so. It is as if I was starting with a brand new session each time, with the three welcome screens. My accounts remain connected, and synch is not triggered. As if Firefox considered everything was OK, while in fact it was reset. BTW, I encountered issues with LinkedIn cookies also recently...

I have created a entirely new profile but since my bookmarks are not correctly synched, I am still wondering how to make this migration complete.
Flags: needinfo?(contact)
I'm so sorry this slipped off my radar, David.

(In reply to David Bourguignon from comment #2)
> I have created a entirely new profile but since my bookmarks are not
> correctly synched, I am still wondering how to make this migration complete.

You can use backup and restore to migrate your bookmarks between profiles. On your old profile, press Ctrl+Shift+B to open the Library, then click Import and Backup > Backup. That'll save a JSON file with all your bookmarks.

On your new profile, disconnect Sync in about:preferences#sync, restore your bookmarks (Import and Backup > Restore > Choose File), and then sign back in to Sync.

I'll close this out as a dupe of bug 1306950, since it sounds like creating a new profile helped. Please reopen or needinfo? me if you still have issues. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1306950
You need to log in before you can comment on or make changes to this bug.