visiting www.sidewalk.com for first time causes endless pop-ups

VERIFIED DUPLICATE of bug 15737

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 15737
19 years ago
14 years ago

People

(Reporter: Bienvenu, Assigned: don)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
The first time I visited www.sidewalk.com, it started putting popups asking for
my zip code, over and over again, until I crashed.

Comment 1

19 years ago
*** Bug 13889 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
I spent a bit of time looking at this and what appears to be happening is that
each of the dialogs comes up as a dialog asking the user to enter a zip code.
the dialog then transforms into the main sidewalk content which creates another
zip code window and then the process repeats. The zip code dialog is generated
from

  var ww;
  ww=window.open("","8429139","width=360,height=300");
  getZipCode(ww, "<B>Welcome to Sidewalk!</B>"+    " Our local version includes
movie times, restaurants, business listings, maps and more.<BR><BR>"+    "<B>
Please enter your ZIP code:</B>");
  function openWW()
  {
  };
  function getZipCode(w1, s)
  {
  	 var d=w1.document;
  	 d.write('<HTML>');
  	 d.write('<HEAD>');
  	 d.write('<TITLE>Welcome to Sidewalk</TITLE>');
  	 d.write('</HEAD>');
  	 d.write('<BODY BGCOLOR="#FFFFFF" TOPMARGIN=10 LEFTMARGIN=10>');
  	 d.write('<FORM NAME="F1" onsubmit="window.opener.setZipCode(self,
window.document.F1.ZIP.value);return false;">');
  	 d.write('<FONT FACE="ARIAL,HELVETICA" COLOR="#006060" SIZE=5>');
  	 d.write('Get your local Sidewalk</FONT><BR>');
  	 d.write('<FONT FACE="ARIAL,HELVETICA" SIZE=2>');
  	 d.write(s);
  	 d.write(' <INPUT TYPE="TEXT" NAME="ZIP" SIZE=5>');
  	 d.write('<INPUT TYPE="IMAGE" ALIGN="ABSBOTTOM" SRC="/images/go.gif" BORDER=0>
');
  	 d.write('<BR><BR><BR><BR><BR><BR>');
  	 d.write('See Sidewalk without local information:');
  	 d.write(' <INPUT TYPE="BUTTON" VALUE="Cancel" onClick=
"window.opener.noZipCode(self)">');
  	 d.write('</FONT>');
  	 d.write('</FORM>');
  	 d.write('</BODY>');
  	 d.write('</HTML>');
  	 d.close();
  };
  function setZipCode(w1, zip)
  {
  	 if (zip == "") {
  	   getZipCode(w1, "Sorry, you forgot to enter a ZIP code.<BR><BR>"+  	     "<
FONT COLOR=#FF0000><B>Please enter your ZIP code:</B></FONT>");
  	 } else if (!validZip(zip)) {
  	   getZipCode(w1, "Sorry, that ZIP code didn't work. Please try again.<BR><BR>
"+  	     "<FONT COLOR=#FF0000><B>Please enter a valid ZIP code:</B></FONT>");
  	 } else {
  	   w1.close();
  	   window.location.href="/?ZIP="+zip;
  	 }
  };
  function validZip(zip)
  {
  	 if (zip.length != 5) {
  	   return false;
  	 }
  	 for (i=0; i<5; i++) {
  	   if (zip.charAt(i) < "0") {
  	     return false;
  	   }
  	   if (zip.charAt(i) > "9") {
  	     return false;
  	   }
  	 }
  	 if (zip == "00000") {
  	   return false;
  	 }
  	 if (zip == "99999") {
  	   return false;
  	 }
  	 return true;
  };
  function noZipCode(w1)
  {
  	 w1.close();
  	 window.location.href="/?WW=0";
  };
  function closeWW()
  {
  	 if (!ww.closed)
    {
  	   ww.close();
    }
  };

which when loaded from a file from apprunner doesn't work. It does work however
in 4.5.

Comment 3

19 years ago
*** This bug has been marked as a duplicate of 15737 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Updated

19 years ago
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.