Closed Bug 1307076 Opened 4 years ago Closed 2 years ago

HLS Player breaks other video types in other tabs

Categories

(Firefox for Android :: Audio/Video, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox51 --- affected
firefox52 --- wontfix

People

(Reporter: u549602, Unassigned)

References

Details

(Keywords: qablocker)

Environment: Aurora 51.0a2
Device: Samsung Galaxy S6 EDGE (Android 6.0);
Build: Aurora 51.0a2 (2016-10-02);

Steps to reproduce:
1. Open two tabs, one with youtube, the other with goo.gl/ZClrcM
2. Let the youtube video play and switch to the HLS tab
3. Play the HLS video
4. Go back to the youtube tab and press play

Expected result:
@ step 3 : Youtube video stops playing
@ step 4: 
1. HLS video should be paused when the youtube resume button is pressed (see bug 1307074 )
2. Yhe youtube video is resumed correctly and continues playing 

Actual result:
@ step 3 : Youtube video stops playing 
@ step 4 : Youtube video player resumes but the video is broken, displaying a blank page with the audio correctly played in the background  

Notes: 
This issue occurs mostly from after the first try
This also occurs when interruping a webm video (http://www.webmfiles.org/demo-files/)
For further details please check https://www.youtube.com/watch?v=DOzbrTgxlxM&feature=youtu.be
Too late for firefox 52, mass-wontfix.
Cannot reproduce this bug in nightly/59 (because of the native HLS playback support in bug 1345752, I believe).

Mihai, could you help confirm that, please? Thanks a lot.
Depends on: HLS_on_Fennec
Flags: needinfo?(mihai.ninu)
Tested again on latest Nightly build, and the issue is not reproducible. Tried with both youtube videos and webm files. 

Devices: Nexus 5 (Android 6.0.1) and Google Pixel (Android 8.0).
Flags: needinfo?(mihai.ninu)
The reporter tested the HLS feature without native supporting.

Since the HLS feature will be phased into Beta 59 and it cannot be reproducible, I mark this as fixed.

Please feel free to reopen it if someone meets the same issue again.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.