Closed Bug 1307127 Opened 3 years ago Closed 3 years ago

Intermittent test_navigation.py TestNavigate.test_error_when_exceeding_page_load_timeout | AssertionError: TimeoutException not raised

Categories

(Testing :: Marionette, defect)

Version 3
defect
Not set

Tracking

(firefox50 fixed, firefox51 fixed, firefox52 fixed)

RESOLVED FIXED
mozilla52
Tracking Status
firefox50 --- fixed
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: ato)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Duplicate of this bug: 1307130
I would assume its a new failure related to the code changes from bug 1302707? Andreas, what do you think?
Flags: needinfo?(ato)
(In reply to Henrik Skupin (:whimboo) from comment #2)
> I would assume its a new failure related to the code changes from bug
> 1302707? Andreas, what do you think?

Possibly.  It’s interesting because line :129 should never really be hit:

    https://github.com/mozilla/gecko-dev/blob/master/testing/marionette/harness/marionette/tests/unit/test_navigation.py#L129

This means that

    self.marionette.navigate(self.marionette.absolute_url("slow"))

sometimes manages to complete, although it should always throw an exception because

    self.marionette.set_page_load_timeout(0)

is being set on the previous line.
Flags: needinfo?(ato)
I think I have found the likely culprit.  driver.js:977 is calling Marionette:pollForReadyState from chrome without passing along all the parameters of the original msg.json structure:

    https://github.com/mozilla/gecko-dev/blob/master/testing/marionette/driver.js#L977

This means the pageTimeout gets lost.
Assignee: nobody → ato
Status: NEW → ASSIGNED
Blocks: webdriver
Comment on attachment 8800376 [details]
Bug 1307127 - Pass along pageTimeout when polling for ready state from chrome;

https://reviewboard.mozilla.org/r/85284/#review85678
Attachment #8800376 - Flags: review?(dburns) → review+
Pushed by atolfsen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2069ba1153a5
Pass along pageTimeout when polling for ready state from chrome; r=automatedtester
https://hg.mozilla.org/mozilla-central/rev/2069ba1153a5
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Sheriffs: This is a test-only fix.
Whiteboard: [checkin-needed-aurora] [checkin-needed-beta]
Whiteboard: [checkin-needed-aurora] [checkin-needed-beta] → [checkin-needed-beta]
Whiteboard: [checkin-needed-beta]
Is this fix added to the latest version geckodriver v0.13.0?
Flags: needinfo?(ato)
The fix on this bug is unrelated to geckodriver, but has been fixed for Firefox 50 and upwards.
Flags: needinfo?(ato)
I use Firefox 50.1.0, but my selenium automation script is still not waiting for Implicit load.

I read in https://github.com/mozilla/geckodriver/issues/96 that the Implicit load issue is partly addressed in this ticket. Can you please confirm if that's the case? Is there any other ticket that needs to be fixed before the Implicit wait works in Marionette driver? Please advise.
Flags: needinfo?(hskupin)
Flags: needinfo?(ato)
As you can see https://github.com/mozilla/geckodriver/issues/96 is still open, and as Andreas mentioned this bug addresses it in parts. There are still remaining issues open for Marionette (eg. reload), but also the general discussion about implicit reloads doesn't seem to have finished. At least that is what I get from the github issue. So all your questions are closer related to this issue as this bug.
Flags: needinfo?(hskupin)
Flags: needinfo?(ato)
You need to log in before you can comment on or make changes to this bug.