Broken header and footer images in message

RESOLVED INVALID

Status

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: uzivatel919, Unassigned)

Tracking

51 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8797309 [details]
The message and screenshots in archive (packed by Peazip).

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393

Steps to reproduce:

I have just got an email.

I am using Earlybird v. 51.0a2 (2016-10-03) (32-bit). The same bug is on Thunderbird v. 45.4.0.


Actual results:

Images from header and footer are shown under the message.


Expected results:

Images are shown in their expected locations.

Comment 1

2 years ago
The MIME structure message is incorrect. The content type shouldn't be multipart/mixed; (message with attachment) but multipart/related (message with related part, usually embedded images).

I changed this to:
Message-ID: <421785168.945135.1475445699026.JavaMail.bea@jok-wls5.cpas.cz>
Subject: RE:WEB Napiste nam
MIME-Version: 1.0
Content-Type: multipart/related; <====

and the message displays just fine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

2 years ago
Oh, that's no big problem. In fact in Windows 10 embed mail client it shows correct. So that's the reason for considering Earlybird is broken.
You need to log in before you can comment on or make changes to this bug.