Can't delete (a particular) IMAP message

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: loz, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
I have one piece of spam in my inbox that I cannot delete.
In fact, selecting it means I can no longer delete any other mail.
The (wierd looking) headers (from view message source) are

Return-Path: <teen4u38756@aol.com>
Message-ID: <20020304233438.9404.qmail@intraforum.net>
From: teen4u38756@aol.com ()
Subject: (reply)
��������������������������������������������������������������������������������e39726
X-UIDL: !c+"!OGf!!oY!#!i[,!!


I'm guessing that that subject line actually contains a lot of unprintable
characters - any way I can test that hypothesis?
(Reporter)

Comment 1

17 years ago
If I select view->headers->all from the menu then I can deal with the message as
per usual. It's only if view->headers->normal is selected that I get the problem.

Updated

17 years ago
QA Contact: esther → huang

Comment 2

17 years ago
I just tried injecting that email into a folder, and it displays fine and I can
delete it without any problems.

Does this still happen in a newer build?
(You forgot to mention which build you are using)

If it does, could right click on the message and click Save As and save that
file and then attach it to the bug?
(Reporter)

Comment 3

17 years ago
I'm using Mozilla-0.9.9. I've not had a chance to pull something newer recently.
I build with -O2 -mcpu=athlon -march=athlon on gcc-3.0.4

The bug is still happening. If I select Save as from Mozilla it truncates the
message to 8kiB so I've attached it direct from my maildir.
(Reporter)

Comment 4

17 years ago
Created attachment 79344 [details]
Problem email

I'm guessing it is text/plain as I can't see another encoding. There is a lot
of HTML in the message though. FOr some reason I couldn't post it with Mozilla.
Maybe I need to change some configuration on my proxy, but I thought I'd try
with another browser first...

Comment 5

16 years ago
Created attachment 103969 [details]
Message Delete Error

Cannot delete any message with 2002091014 (Mozilla/5.0 (Windows; U; Windows NT
5.0; en-US; rv:1.2a) Gecko/20020910)

Comment 6

16 years ago
Cannot delete any message with 2002091014 (Mozilla/5.0 (Windows; U; Windows NT
5.0; en-US; rv:1.2a) Gecko/20020910). This bug should be marked CRITICAL.

Comment 7

16 years ago
Could you please download a recent nightly build from
<ftp://ftp.mozilla.org/pub/mozilla/nightly/>, and then let us know if you 
still see this problem?

Thanks

Comment 8

16 years ago
reporter, can you save the file as .eml file and post it as attachment?

Comment 9

16 years ago
I am not sure if this is related, but someone sent me a 16meg attachment (yes, I
yelled at them) which, when I deleted it, seemed to cause the creation of an
e-mail with the date 12/31/1969 which I cannot delete (or move). It has happened
once more since then (again, after getting a large attachment and trying to
delete it).

I got this while using the released version of 1.2.1 and have since upgraded to
the released version of 1.3 (which will still not let me delete it).
(Reporter)

Comment 10

16 years ago
Created attachment 122510 [details]
Problem email (2)

This is the same as the previous attachment, just posted as
application/octet-stream, so hopefully non of the strange header characters are
lost.
I still appear to get the problem, and still only if view->headers->normal is
selected rather than all...
(Reporter)

Comment 11

16 years ago
Sorry, should of said, I'm using 1.4a now.
I've just done a bit more experimenting and the bug is largely better now. The
only problem I get is with headers set to normal.
1. move problem email from folder 1 to folder 2
2. select folder 2
3. attempt to move problem email from folder 2 to folder 3 (fails)
4. attempt to delete problem email (Fails)
5. select folder 1
6. select folder 2
7. attempt to move problem email from folder 2 to folder 3 (succeeds)

Comment 12

15 years ago
Loz, have you tried reproducing this bug with a recent build? If you don't see
this any more, the bug could be closed.
(Reporter)

Comment 13

15 years ago
I can't reproduce either the original problem, or the second lesser problem from
comment #11.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

15 years ago
I'm using 1.5 now.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.