Intermittent ogg-video/poster-7.html == file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/ogg-video/poster-ref-red140x100.html | image comparison, max difference: 243, number of differing pixels: 50000

RESOLVED FIXED in Firefox 51

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: intermittent-bug-filer, Assigned: stone)

Tracking

({intermittent-failure})

unspecified
mozilla52
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 unaffected, firefox51 fixed, firefox52 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Likely regression from https://hg.mozilla.org/mozilla-central/rev/2c3aadf10c99 -- can you have a look, :stone?
Blocks: 1292063
Flags: needinfo?(sshih)
Assignee: nobody → sshih
Flags: needinfo?(sshih)
Checked current implementation and found that HTMLImageElement in some cases does not delay document to fire load event until the image is loaded. We need to fix this behavior to follow spec and fix this intermittent failure.

The video poster behavior is defined in [1] step5

[1] http://w3c.github.io/html/semantics-embedded-content.html#element-attrdef-video-poster
ni myself for tracking.
Flags: needinfo?(echen)
I wrote a test script, http://software.hixie.ch/utilities/js/live-dom-viewer/?saved=4573, and it looks like image element do delay the document load event. So I am guessing this intermittent failure is caused by other reason.
Flags: needinfo?(echen)
(In reply to Edgar Chen [:edgar][:echen] (PTO 10/14~10/17) from comment #9)
> I wrote a test script,
> http://software.hixie.ch/utilities/js/live-dom-viewer/?saved=4573, and it
> looks like image element do delay the document load event. So I am guessing
> this intermittent failure is caused by other reason.

Thanks for your helps to clarify it.
Had some discussions with edgar and found the intermittent may be caused by the timing of change video poster and compare results. Now we can't change poster when video onload because we don't fire load event on video to follow spec. This patch change video poster right after video element. When video poster is changed and trigger loading image, it should block document onload event so we can trigger comparison at body onload.

Had tried in [1] and no video poster related intermittent failures. Also had tried in [2] w/o this patch and there are some poster related intermittent failures.

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=b10a23e87aa23b3e446bffd8a97da4e2c70ad749
[2] https://treeherder.mozilla.org/#/jobs?repo=try&revision=0bdcbc158ffda7efab09bf14343e341d9ae3f076&selectedJob=29201506
Attachment #8801618 - Flags: review?(bugs)
Attachment #8801618 - Flags: review?(bugs) → review+
Updated the patch summary.
Attachment #8801618 - Attachment is obsolete: true
Attachment #8801948 - Flags: review+
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d583050cc25b
Fix intermittent poster-7.html reftest failed. r=smaug.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d583050cc25b
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Whiteboard: [checkin-needed-aurora]
has problems uplifting to aurora

merging layout/reftests/webm-video/poster-7.html
warning: conflicts while merging layout/reftests/ogg-video/poster-4.html! (edit, then use 'hg resolve --mark')
warning: conflicts while merging layout/reftests/ogg-video/poster-7.html! (edit, then use 'hg resolve --mark')
warning: conflicts while merging layout/reftests/webm-video/poster-4.html! (edit, then use 'hg resolve --mark')
warning: conflicts while merging layout/reftests/webm-video/poster-7.html! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue
(use 'hg resolve' and 'hg graft --continue')
Flags: needinfo?(sshih)
Flags: needinfo?(sshih)
You need to log in before you can comment on or make changes to this bug.