Google Slides causing heavy CPU load

RESOLVED DUPLICATE of bug 1334632

Status

()

Core
General
RESOLVED DUPLICATE of bug 1334632
2 years ago
7 months ago

People

(Reporter: hmitsch, Unassigned)

Tracking

51 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(platform-rel -)

Details

(Whiteboard: [platform-rel-Google][platform-rel-GoogleSuite][platform-rel-GoogleSlides][qf])

(Reporter)

Description

2 years ago
Sorry for opening this bug late. It might be well known already, in this case please close the ticket. I am happy to add me to the CC-list of a different issue.

Since quite a while (maybe since e10s is on Aurora for MacOS?) using complex Google documents causes my Macbook's CPU load to go up really high.

I tried using Chrome and it works much better.

Is this a known issue? I am happy to provide example documents.
Steve, I noticed you've been doing some work on google docs perf - any ideas about whether this is already tracked somewhere?

Henrik: a test document would be helpful, I think.
Component: General → Untriaged
Flags: needinfo?(sphink)
Flags: needinfo?(hmitsch)
Product: Firefox → Core
(Reporter)

Comment 2

2 years ago
Example documents which kill my MacBook Air 13-inch, mid 2012 (2 Ghz Intel i7):

- Participation Systems Strategic Plan: https://docs.google.com/presentation/d/1ZWCPWtvoFtEG8gNhVLcHodOJ91sEAWzpA7X-MTUOjNQ/edit#slide=id.g154e68ba30_1_720
- Participation Demos Q3 2016: https://docs.google.com/presentation/d/13JhXLc12XJ5JDBfCGzkend0BUosq6BtysgZs_PARd_0/edit#slide=id.g1368802af2_0_10

-Henrik
Flags: needinfo?(hmitsch)
The first document doesn't seem to produce much load on my Linux machine running Nightly. I will be getting a Mac Mini this week and will re-test there; I am particularly interested in OSX-specific Google Docs slowdowns right now.

In the meantime, could we get an Ubuntu Hasal numbers for these, to compare between Firefox and Chrome? Thanks! (And let me know if it's too much trouble to test random pages like this.)
Flags: needinfo?(sphink) → needinfo?(bchien)
Oops, wanted to leave ni? me for the OSX perf test.
Flags: needinfo?(sphink)

Updated

2 years ago
Summary: Google Docs causing heavy CPU load → Google Slides causing heavy CPU load

Comment 5

2 years ago
(In reply to Henrik Mitsch [:hmitsch] from comment #0)
> Since quite a while (maybe since e10s is on Aurora for MacOS?) using complex
> Google documents causes my Macbook's CPU load to go up really high.
> 

Henrik, let me figure when you mentioned CPU high, is it from Mac CPU monitor? or do you feel firefox slow from perceive perspective?

I don't have CPU issue from my Macbook Pro. However, yes, I feel firefox dose play slower on your documents than Chrome on my side. I don't have benchmark so far. Hasal team is working on benchmark on Google Sheets and Slides this month. Please stay tune before we publish data.
(Reporter)

Comment 6

2 years ago
@Bobby,

with my old Macbook it is both: CPU high in Mac CPU monitor AND very slow Firefox experience.
With my brand new Macbook Pro (early 2015 model), the Firefox experience is still slow and heavily degraded.

-H

Updated

2 years ago
Blocks: 1308111
platform-rel: --- → ?
Whiteboard: [platform-rel-Google][platform-rel-GoogleDocs][platform-rel-GoogleSlides]
Whiteboard: [platform-rel-Google][platform-rel-GoogleDocs][platform-rel-GoogleSlides] → [platform-rel-Google][platform-rel-GoogleSuite][platform-rel-GoogleSlides]

Updated

2 years ago
platform-rel: ? → -

Comment 7

2 years ago
Any idea for a component for this bug? I looked on bug 1208111 the meta bug and many of the bugs related to this issue are on general. We don't have a specific component for this kind of issues so I think it should go under General, at least until we will have a component for this. Any ideas?

Updated

a year ago
Component: Untriaged → General
This bug wasn't discovered via a Hasal test so I'm going to remove it from blocking the Hasal-GSlides meta. I considered creating another "GSlides perf issues" meta but decided not to in the end.
No longer blocks: 1308111

Updated

a year ago
Flags: needinfo?(bchien)
Whiteboard: [platform-rel-Google][platform-rel-GoogleSuite][platform-rel-GoogleSlides] → [platform-rel-Google][platform-rel-GoogleSuite][platform-rel-GoogleSlides][qf]
Let's dupe this to the meta GSlides bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334632
Flags: needinfo?(sphink)
You need to log in before you can comment on or make changes to this bug.