Closed Bug 1307413 Opened 3 years ago Closed 3 years ago

Firefox Uninstalls On Boot - Windows 10 Anniversary Update

Categories

(Web Compatibility :: Desktop, defect)

x86_64
Windows 10
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1307418

People

(Reporter: shaquille110, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [platform-rel-Microsoft][platform-rel-Windows])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393

Steps to reproduce:

1. Downloaded Windows 10 Anniversary Update Client from MSFT website (https://support.microsoft.com/en-us/help/12387/windows-10-update-history)
2. Installed update and selected to delete old files and start fresh.
3. Using Edge once update installed, download Firefox from the Firefox/Mozilla website.
4. Changed default browser to Firefox.
5. Changed MSFT Data Collection settings (app, browsing and advertising) to off.
6. Restarted Computer 
7. Firefox is no longer installed, firefox directly missing from installed directory.
8. Firefox shortcuts no longer work on Desktop (firefox.exe missing)


Actual results:

Firefox file directory (program files) and associated files are removed. Including Registry keys.


Expected results:

Firefox to not be uninstalled.
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
See Also: → 1307418
Thanks for the report! I've asked some of our friends at Microsoft via email if they know what's up here.
Blocks: windows-10
platform-rel: --- → ?
Whiteboard: [platform-rel-Microsoft][platform-rel-Windows]
(In reply to Andrew Overholt [:overholt] from comment #1)
> Thanks for the report! I've asked some of our friends at Microsoft via email
> if they know what's up here.

No problem. I encountered another problem with AMD Control Centre having a similar issue but its replaced with an older version. Which may explain 1307039 ???

https://www.reddit.com/r/Windows10/comments/3twg2m/windows_10_is_uninstalling_user_apps_without/
(In reply to Shaquille Ray from comment #2)
> (In reply to Andrew Overholt [:overholt] from comment #1)
> > Thanks for the report! I've asked some of our friends at Microsoft via email
> > if they know what's up here.
> 
> No problem. I encountered another problem with AMD Control Centre having a
> similar issue but its replaced with an older version. Which may explain
> 1307039 ???
> 
> https://www.reddit.com/r/Windows10/comments/3twg2m/
> windows_10_is_uninstalling_user_apps_without/

Correction bug 1305787
Component: Untriaged → General
Given that this isn't Firefox doing anything strange, going to move this to tech evangelism as it's effectively an outreach issue.
Component: General → Desktop
Product: Firefox → Tech Evangelism
Looks like activity will happen in bug 1307418.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
platform-rel: ? → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 1307418
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.