OpenLayers 3 does not work on some systems

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
2 years ago
23 hours ago

People

(Reporter: fabien.fivaz, Unassigned, NeedInfo)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160923225245

Steps to reproduce:

I have a FAIRPHONE (Android kitkat 4.2.2) with Firefox 49.0 freshly installed (no cache, no special settings). I load a webpage with OpenLayers 3 (OL3) examples (http://openlayers.org/en/latest/examples/). To be precise, take the Bing Maps example (http://openlayers.org/en/latest/examples/bing-maps.html), but many other examples fail as well.


Actual results:

Firefox for Android does not render OL3 canvas correctly. For instance, the Bing maps example does load the OL canvas, with the three basic buttons (+, -, i), but NOT the satellite images it should. 

If I look at the Developer tools and connect to my phone, all the tiles with the satellite images are loading (network tool) but not showing.


Expected results:

The canvas should have loaded correctly. I tested the same examples with Firefox 49.0 on another android phone (Moto G3 with cyanogenmod 13), it works. I tested the same webpage with Chrome 53 on the FAIRPHONE and it works.

Comment 1

19 days ago
Hello Fabien,

I couldn't reproduce this issue following the steps from the description on the latest Nightly with Samsung Galaxy S8+ Android 8.0.0.
Can you please check if this issue is still reproducible to you? If you manage to reproduce the issue please mention the device and the android version.

Thanks,
Andrei
Flags: needinfo?(fabien.fivaz)

Comment 2

23 hours ago
Due to the lack of additional info, I'll close this issue as Incomplete. If the issue can be confirmed please reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 23 hours ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.