Mozilla doesn't (re)draw screen when it should

RESOLVED DUPLICATE of bug 133132

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 133132
16 years ago
13 years ago

People

(Reporter: Lasse Kärkkäinen, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Something - haven't yet figured what - makes Mozilla stop drawing stuff on the
screen. After ALT-TAB (task-switch) Mozilla only draws some tiny pieces of the
UI, not the whole UI or the webpage. This makes it almost impossible to use Mozilla.

When Mozilla goes to this "mode" (=not drawing properly), it will stay there
until next reboot. Restarting Mozilla, making the Mozilla window smaller or
closing other applications might help temporarily, but the problem will reappear
shortly.

Most UI elements become visible when you move mouse over or click. Text on
webpages must be selected to make it visible. Pictures on webpages become
visible on click. Moving forward (following links) seems to draw pages
correctly, even in this mode, but hitting back-button doesn't draw anything.

This bug has been around for a LONG time (so long that I can't even remember
when it first appeared, or if it has always been there).

I currently have 53% free GDI and 52% free user-resources, so that shouldn't be
a problem. Other programs run just fine. Mozilla dialogs (download-dialog, for
example) don't seem to be affected by this bug, but I can't verify that.

A screenshot cannot be taken; as Mozilla doesn't draw (almost) anything, the
screenshot is full of black. I took some "shots" with a videocam; if you need
that stuff for resolving this bug, let me know and I'll put that video on the net.

One ugly workaround would be assigning a hotkey for redrawing everything.
build ID ?
(Reporter)

Comment 2

16 years ago
Any build, old or new. Currently running 2002031309 and the bug is there.

Comment 3

16 years ago
Reporter:

Please try a more new one with a clean installation (install in a new
directory). And does this only happens after viewing websites with a Java plug in?

Comment 4

16 years ago
This sounds just like bug 133132. The redraw problem and black-and-white screen
capture, as well as that it occurs on Windows 98 and is only fixed by a reboot,
are all elements in common. If the problem presists after you completely
reinstall Mozilla and create a new profile, please vote for bug 133132 and list
what graphics card you use.

Comment 5

16 years ago
I have seen (i think) this behaviour too. First time it happened was when I
installed this build (download talkback zip, unzip to new directory, quit
previous version of Mozilla). Must have been around 5-30-02. Then I started this
build, hit slashdot, clicked on a story, and the screen was not drawn. The load
progress bar stayed at about 95%, and the mozilla icon kept animating, even
thought the pageload was complete. I could only get the page to show by dragging
the mozilla window off screen, and back. Then I went to bugzilla to search for
this bug, which is quite annoying if you have to move your browser around
everytime you click a link... Restarting the browser didn't help, only rebooting
windows fixed it. Never happened again, until today. Only this time I also saw
some images painted in black and white after moving the browser window out of
sight and back. It happened when I went to this site,
http://news.bbc.co.uk/hi/english/sci/tech/newsid_2034000/2034187.stm , from
slashdot again. This time restarting the browser fixed it.

videocard: winfast geforce3, nvidia drivers 4.13.01.2832, pinball theme installed.

Have no idea on how to reproduce it, so I'm not going to switch to a new profile
just to keep testing.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/200205304

Comment 6

16 years ago
Resolving as we have never heard anything back from reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

16 years ago
The bug still exists, it seems. Last time I saw it (or very similar bug) was
yesterday: I was scrolling a page with grey background, but Mozilla painted
white instead. Using 2002062408.

I still haven't been able to test this on clean install, but I think that it is
somehow related to using Newtek's LightWave. I hadn't seen this bug for a while,
but after I began to use LW again a week ago, I have seen this couple of times.

Anyway, I'm not 100% sure if these new problems are same as before. I have
closed Mozilla and rebooted when something hasn't been drawn correctly. Next
time it happens, I'll try to analyze it a bit more. If that doesn't happen in a
week, you can consider this bug fixed.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 8

16 years ago

*** This bug has been marked as a duplicate of 133132 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.