Closed Bug 1307464 Opened 6 years ago Closed 4 years ago

MIgrate the shader editor tooltip to HTML tooltip

Categories

(DevTools Graveyard :: WebGL Shader Editor, enhancement, P3)

enhancement

Tracking

(firefox63 fixed)

RESOLVED FIXED
Firefox 63
Tracking Status
firefox63 --- fixed

People

(Reporter: gl, Assigned: jdescottes)

References

Details

Attachments

(3 files)

The work required for this bug is to migrate the shader editor tooltip to HTML tooltip and then move the XUL tooltip to the debugger module. This way it would no longer pollute the widgets folder and would be removed automatically when the old debugger gets removed.
needinfo'd you julian in case you wanted to take it. I don't have the necessary bandwidth to work on this at the moment.
Flags: needinfo?(jdescottes)
Sure, thanks for logging it!
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Flags: needinfo?(jdescottes)
Severity: normal → enhancement
Product: Firefox → DevTools
Duplicate of this bug: 1322456
How to test this:
- go to any WebGL demo site (eg http://alteredqualia.com/three/examples/webgl_pasta.html)
- open Shader Editor
- click on reload button in the Shader Editor
- delete some random code in text editor to trigger errors
- hover on the error icons appearing in the gutter
Here is a screenshot of the new tooltip in dark theme.
Same in light theme
Comment on attachment 8995435 [details]
Bug 1307464 - Use HTMLTooltip in shader editor;

https://reviewboard.mozilla.org/r/259884/#review266892

That looks good to me ! (and now I'm hungry with all those pastas flying around :) )
Thanks Julian
Attachment #8995435 - Flags: review?(nchevobbe) → review+
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d7039031e380
Use HTMLTooltip in shader editor;r=nchevobbe
Blocks: 1479006
https://hg.mozilla.org/mozilla-central/rev/d7039031e380
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.