Zone::isCollectingFromAnyThread is not thread-safe

RESOLVED DUPLICATE of bug 1313098

Status

()

Core
JavaScript: GC
RESOLVED DUPLICATE of bug 1313098
2 years ago
2 years ago

People

(Reporter: jonco, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
This checks the runtime's heap state which is protected by the helper thread state lock, without taking the lock.  Note that this may not be an issue after we stop firing barriers off main thread (bug 1302559).
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1313098
You need to log in before you can comment on or make changes to this bug.