Links can't be clicked when wrapping img's and not defined as block level in CSS.

RESOLVED DUPLICATE of bug 1374283

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 1374283
3 years ago
a year ago

People

(Reporter: agibson, Unassigned)

Tracking

(Depends on 1 bug, Blocks 1 bug)

Version 3
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

3 years ago
Posted file fxos-tv.py
Attached a test-case script to reproduce the issue.

The issue occurs on links like this:

<a href="#tv2" id="tv2-tab" role="tab" aria-controls="tv2" aria-selected="false">
  <img src="/media/img/firefox/os/devices/tv/screen2.ec03ac45bd01.jpg" alt="Screenshot">
</a>

Marionette clicks the link, but nothing happens - presumably because it just clicks the image instead.

A workaround is to set the link to be block-level in the page's CSS:

a {
  display: block;
}
Reporter

Comment 1

3 years ago
I should also add the versions of what I'm using:

[Selenium 3.0.0b3 / Geckodriver v0.10.0 / Firefox 49.0.1]
Attachment #8798007 - Attachment mime type: text/x-python-script → text/plain
Looks like to be similar to bug 1374283. Maybe it will fix it.
Depends on: 1374283
Priority: -- → P3
I wonder if this was resolved by moving to the WebDriver-conforming
Element Click implementation.
Blocks: webdriver
Priority: P3 → P2
I would say we dupe against bug 1374283.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1374283
You need to log in before you can comment on or make changes to this bug.