Tool bar "delete" button is not operating at all

UNCONFIRMED
Unassigned

Status

Thunderbird
Mail Window Front End
UNCONFIRMED
a year ago
a year ago

People

(Reporter: giuseppe.altieri, Unassigned, NeedInfo)

Tracking

45 Branch
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

- Select a message
- Hit "delete" on tool bar


Actual results:

the selected message is not deleted.


Expected results:

the selected message is deleted.
(Reporter)

Updated

a year ago
Component: Untriaged → General
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64
Works for me. Please try with all add-ons disabled (see Help menu).
(Reporter)

Comment 2

a year ago
(In reply to Jorg K (GMT+2) from comment #1)
> Works for me. Please try with all add-ons disabled (see Help menu).

I disabled all add-ons but still cannot delete messages from "delete" toolbar. Sorry. This happens until last thunderbird version (45.4.0, Italian) and I remember it started to appear from a certain thunderbird version update onward. Previously this was functioning.
There is no "delete" toolbar. Are you referring to the delete button in the message pane/header pane?
(Reporter)

Comment 4

a year ago
(In reply to Jorg K (GMT+2) from comment #3)
> There is no "delete" toolbar. Are you referring to the delete button in the
> message pane/header pane?

Sorry, I use "delete" button on toolbar.
I now tested that is not functioning even "delete message" in menubar and "delete" on keyboard !!!
In addition, when trying to delete an unread message it is marked as read.
To delete a message I need to move it into trash by mouse.
re you using IMAP? If yes, you need to play in Account Manager with the Server Settings what should happen to the deleted messages. Maybe an unannounced chage on server side happened.
(Reporter)

Comment 6

a year ago
(In reply to Richard Marti (:Paenglab) from comment #5)
> re you using IMAP? If yes, you need to play in Account Manager with the
> Server Settings what should happen to the deleted messages. Maybe an
> unannounced chage on server side happened.

I'm using POP. I cannot know the details, but, to my knowledge, it seems that for some reason the queued message of deletion is lost or not executed or not received.
(Reporter)

Comment 7

a year ago
Hey guys,
this error appears into errors console:
Data e ora: 07/10/2016 12:05:27
Errore: An error occurred executing the button_delete command: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgDBView.doCommand]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/folderDisplay.js :: FolderDisplayWidget_doCommand :: line 1846"  data: no]
File sorgente: chrome://global/content/globalOverlay.js
Riga: 103
Can this help?
Note much:
  doCommand: function FolderDisplayWidget_doCommand(aCommandName) {
    return this.view.dbView && this.view.dbView.doCommand(aCommandName); <=== line 1846
  },

Looks like the deletion really fails ;-)

Aceman, can I get you interested in this?
(In reply to Jorg K (GMT+1) from comment #8)
> Note much:
>   doCommand: function FolderDisplayWidget_doCommand(aCommandName) {
>     return this.view.dbView && this.view.dbView.doCommand(aCommandName);
> <=== line 1846
>   },
> 
> Looks like the deletion really fails ;-)
> 
> Aceman, can I get you interested in this?

it's a bit unrefined, bug xref https://mzl.la/2eVRzBX
Component: General → Mail Window Front End
Flags: needinfo?(acelists)
You need to log in before you can comment on or make changes to this bug.