Closed Bug 1307779 Opened 3 years ago Closed 3 years ago

Pressing volume down shows tab history panel

Categories

(Firefox for Android :: General, defect, P1)

All
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 52
Iteration:
1.6
Tracking Status
firefox49 --- unaffected
fennec 50+ ---
firefox50 + verified
firefox51 + verified
firefox52 + verified

People

(Reporter: sebastian, Assigned: ahunt)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [MobileAS])

Attachments

(1 file)

I assume this is a regression from bug 1304688: When pressing the hardware volume down button the tab history panel shows up (Nexus 6P, Android 7.0).
@ahunt: Are you seeing this too?
Flags: needinfo?(ahunt)
(In reply to Sebastian Kaspari (:sebastian) from comment #1)
> @ahunt: Are you seeing this too?

Yes.

And I realise now that I forgot to test that it's the back key that's being pressed in onKeyDown() : /.
Assignee: nobody → ahunt
Flags: needinfo?(ahunt)
Priority: -- → P1
Whiteboard: [MobileAS]
I filed Bug 1307836 to add tests for this, but I'm not sure how feasible adding tests actually is (we'd need to setup emulators for multiple android versions...).

With my patch (see next comment), I've confirmed that both on an Android 7 (N) and an Android 4.4 device:
- Single press back button works as expected
- Long press shows history
- Pressing volume up / down dowsn't show history
Status: NEW → ASSIGNED
Blocks: 1307836
[Tracking Requested - why for this release]: Regression introduced in Bug 1304688, affects all Android 7 devices: we'll show the history panel for all button presses (primarily volume down/up).
Comment on attachment 8798130 [details]
Bug 1307779 - Only start long-press timer for back button

https://reviewboard.mozilla.org/r/83676/#review82242
Attachment #8798130 - Flags: review?(s.kaspari) → review+
tracking-fennec: ? → 50+
Pushed by ahunt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/23b4707ed4f9
Only start long-press timer for back button r=sebastian
Tracking because it is a new regression which never shipped to our users.

Andrzej, Could you fill the uplift request? Thanks
Flags: needinfo?(ahunt)
Keywords: regression
https://hg.mozilla.org/mozilla-central/rev/23b4707ed4f9
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Can you request uplift for the release channels we uplifted the patch in bug 1304688 to?
Comment on attachment 8798130 [details]
Bug 1307779 - Only start long-press timer for back button

Approval Request Comment
[Feature/regressing bug #]: Bug 1304688 introduced this regression, while trying to work around an Android 7 system bug.
[User impact if declined]: Only on Android 7: pressing volume up/down (or any other hardware button other than the back button) results in the tab-history panel being shown after a ~3s delay.
[Describe test coverage new/current, TreeHerder]: manual testing on nightly, on both older (Android <=6) and newer (Android 7) devices.
[Risks and why]: Low risk: an additional condition has been added to the test for starting the backpress timer, this ensures that we only start the timer for the back button (but not other buttons).
[String/UUID change made/needed]: none.
Flags: needinfo?(ahunt)
Attachment #8798130 - Flags: approval-mozilla-beta?
Attachment #8798130 - Flags: approval-mozilla-aurora?
Comment on attachment 8798130 [details]
Bug 1307779 - Only start long-press timer for back button

Fixes a new regression in 50, Aurora51+, Beta50+
Attachment #8798130 - Flags: approval-mozilla-beta?
Attachment #8798130 - Flags: approval-mozilla-beta+
Attachment #8798130 - Flags: approval-mozilla-aurora?
Attachment #8798130 - Flags: approval-mozilla-aurora+
Verified this on Nexus 6P(Android 7.0) on Firefox 50 Beta, latest Aurora and latest Nightly
Iteration: --- → 1.6
You need to log in before you can comment on or make changes to this bug.