Problem connecting to certain IMAP server when proxy is used

VERIFIED INVALID

Status

MailNews Core
Networking: IMAP
VERIFIED INVALID
16 years ago
9 years ago

People

(Reporter: Peter Anderson, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
After downloading and upgrading to Mozilla 0.9.9 I was unable to connect to the
IMAP mail server at work. The mail server returns the following when telnetting
to port 143:

Solstice (tm) Internet Mail Server (tm) 2.0p12 IMAP4 service

Presumably this is a very old mail server as our corporate standard is supposed
to be iPlanet Messaging 5.0

When trying to connect to the mail server, the status bar shows activity but
nothing happens for quite some time until it times out and says the server has
refused the connection. After trying numerous different ways of
installing/uninstalling, etc I had to go back to 0.9.8 which performs slowly but
satisfactorily.
Reporter: 
Do you use a proxy ?
If yes: Have you a "no proxy" entry for your Imap server ?
(BTW: we changed this betwenn 0.9.8 and 0.9.9) 

You can read this in the release notes (and you should read this before you file 
a bug)

Comment 2

16 years ago
Same observation here with 

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

we are also using SIMS as mailserver. Some more investigation:

Running a network sniffer shows, that despite networking is set up correctly
(dns works, servers are reachable via telnet (manually typing IMAP commands
works fine)), Mozilla does not even initiate network traffic to the IMAP server.
To verify that I was using the network sniffer correctly, I shut down mozilla,
and started another mail client (netscape 4.79) to connect to the mail server -
which worked without problems.

Restarting mozilla with  IMAP logging enabled (NSPR_LOG_MODULES=IMAP:5) just
reveals one line:

8201[874b2d0]: <servername>:NA:CreateNewLineFromSocket: (null)

Christian Funke : Do you use a proxy/socks server ? (for http...)

Comment 4

16 years ago
Hello Matti: Yes - and I just verified, that in fact things work again if I put
the domain the imap server is in into the "No Proxy for:" field. 

This is _very_ strage behavior, because there is no indication for the user that
the proxy setting may interfere with IMAP functionality...
CC bbaetz for the last question
bbaetz: 
Maybe we should add a pref "use Proxy for Mailnews" ?
We got many bugs about this and also many people ask in the newsgroups about this..

Comment 6

16 years ago
Such kind of button would help very much. From the current point of view, it is
not even clear which proxy is used, as you can specify different ones for
different protocols, but not for mailnews.
AFAIK only Socks

Comment 8

16 years ago
>Christian Funke : Do you use a proxy/socks server ? (for http...)
>Hello Matti: Yes - and I just verified, that in fact things work again if I put
>the domain the imap server is in into the "No Proxy for:" field. 

Based on above comments, reassigning this bug QA to Stephen.

QA Contact: huang → stephend

Updated

16 years ago
Summary: Problem connecting to certain IMAP server → Problem connecting to certain IMAP server when proxy is used
If you don't have a SOCKS server, then don't tell mozilla that you do. I'm open
to suggestions to make this more obvious, since lots of people just fill in
everything with the same server name. Sugestions?

Comment 10

16 years ago
How about adding a checkbox "Use SOCKS proxy for Email"?
Not really...

Are you actually in the position of having to use a socks proxy for external
sites, but internal web sites do work AND your domain isn't in the no proxy for
field AND it doesn't work for external sites?

That situation is really unlikely.

I think we just want to indicate that 'filling in all the boxes' probably isn't
want you want. A separate group box, maybe?

mpt, thoughts?
We have a bug about adding a "proxy for all" field.
We could do this and put the socks pref in an own group.
-> invalid (the problem itself is invalid)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
verified invalid.  there are open bugs about moving/extending the 'no proxy for'
UI into mail accounts.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.