add adjust-sdk and adjust-sdk-beta token files to android builds via secret service

RESOLVED FIXED in mozilla52

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jlund, Assigned: jlund)

Tracking

unspecified
mozilla52
Dependency tree / graph

Details

Attachments

(1 attachment)

No description provided.
Assignee: nobody → jlund
(In reply to Jordan Lund (:jlund) from comment #1)
> Created attachment 8798215 [details]
> Bug 1308010 - add adjust-sdk and adjust-sdk-beta token files to android
> builds via secret service
> 
> Review commit: https://reviewboard.mozilla.org/r/83738/diff/#index_header
> See other reviews: https://reviewboard.mozilla.org/r/83738/

I think this is all that is needed. I'm making some assumptions though.

1. these files are already in secret service and the same ones (file name + contents) are currently being used for linux64
    * https://dxr.mozilla.org/mozilla-central/rev/ea104eeb14cc54da9a06c3766da63f73117723a0/testing/mozharness/configs/builds/releng_base_linux_64_builds.py#53 

2. it's okay to download these on trunk/aurora even though we only need them for beta/release.
    * as this is the current behaviour for linux64 anyway

3. we don't need any additional scopes added
    * based on the fact that we already have one secret downloaded for android with the same base scope: project/releng/gecko/build/level-2 and these tasks should be created with that scope available: https://tools.taskcluster.net/auth/scopes/#secrets:get:project%252freleng%252fgecko%252fbuild%252flevel-2%252f*/


will try on try now to at least negative test regressions
Those assumptions all seem perfectly valid to me.

Comment 5

3 years ago
mozreview-review
Comment on attachment 8798215 [details]
Bug 1308010 - add adjust-sdk and adjust-sdk-beta token files to android builds via secret service

https://reviewboard.mozilla.org/r/83738/#review82442
Attachment #8798215 - Flags: review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/6b60177d1a3faf6c34662b00ce1469c0c1a96bd3
Bug 1308010 - add adjust-sdk and adjust-sdk-beta tokens to builds via secret service, r=dustin
(In reply to Dustin J. Mitchell [:dustin] from comment #5)
> Comment on attachment 8798215 [details]
> Bug 1308010 - add adjust-sdk and adjust-sdk-beta token files to android
> builds via secret service
> 
> https://reviewboard.mozilla.org/r/83738/#review82442

thanks, I was on PTO so only getting back to this now. Will uplift shortly. Would be nice to fix during merge day so we can unlock tc builds on beta+release

Comment 8

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6b60177d1a3f
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
uplifted to mozilla-release (since we just merged beta->release today). 

if tc android builds look good here: https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&revision=cdb23cfd36e28dd993361b60a1e5572ee3508420&exclusion_profile=false&filter-searchStr=tc%20android%20B

I'll revert the tier 2 demotion in bug 1303914
(In reply to Jordan Lund (:jlund) from comment #9)

> if tc android builds look good here:
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-
> beta&revision=cdb23cfd36e28dd993361b60a1e5572ee3508420&exclusion_profile=fals
> e&filter-searchStr=tc%20android%20B
> 
> I'll revert the tier 2 demotion in bug 1303914

they look good. reverting now.
You need to log in before you can comment on or make changes to this bug.