Provide Tomcat support for TLS v1.1 and TLS v1.2 via NSS through JSS

RESOLVED FIXED in 4.4

Status

JSS
Library
RESOLVED FIXED
a year ago
7 months ago

People

(Reporter: Elio Maldonado, Assigned: Christina Fu)

Tracking

Details

Attachments

(1 attachment, 3 obsolete attachments)

Comment hidden (empty)
(Reporter)

Updated

a year ago
Blocks: 1307859
(Reporter)

Comment 1

a year ago
Created attachment 8798966 [details] [diff] [review]
support TLS 1.1 and TLS1.2

Downstream patch by Christina Fu, not ready yet for reviw
(Reporter)

Comment 2

11 months ago
Comment on attachment 8798966 [details] [diff] [review]
support TLS 1.1 and TLS1.2

Review of attachment 8798966 [details] [diff] [review]:
-----------------------------------------------------------------

This patch caused build to fail (1 error and 4 warnings) will attach the error log.
(Reporter)

Comment 3

11 months ago
Created attachment 8835188 [details]
build.log
(Reporter)

Comment 4

11 months ago
Created attachment 8835189 [details]
error log

Generated via make clean all 1> ../tls-1.2-build.log 2> ../tls-1.2-error.log
(Reporter)

Updated

11 months ago
Assignee: glenbeasley → cfu
(Reporter)

Comment 5

11 months ago
Created attachment 8843535 [details] [diff] [review]
support TLS1.1 and TLS1.2

This one solves the problems I had once the one for Bug 1344292 has been committed.
Attachment #8798966 - Attachment is obsolete: true
Attachment #8835188 - Attachment is obsolete: true
Attachment #8835189 - Attachment is obsolete: true
Attachment #8843535 - Flags: review?(cfu)
(Assignee)

Comment 6

11 months ago
Comment on attachment 8843535 [details] [diff] [review]
support TLS1.1 and TLS1.2

Review of attachment 8843535 [details] [diff] [review]:
-----------------------------------------------------------------

This patch matches closely with my original Fedora downstream JSS patch jss-support-TLS1_1-TLS1_2.patch
with the exception of the enum downshifting which most likely was caused by the merge with upstream existing numbers clash.
That was fine.
However, the following
#define JSSL_enums_size 36
should be
#define JSSL_enums_size 35

You can just make that correction and it's good.
(Reporter)

Comment 7

11 months ago
Pushed: https://hg.mozilla.org/projects/jss/rev/c37b03bda9afc470bd412bf89428f17c120dc995
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
(Reporter)

Comment 8

11 months ago
Historical Note:
# RHBZ 816396 - Provide Tomcat support for TLS v1.1 and TLS v1.2 via NSS through JSS
# https://bugzilla.redhat.com/show_bug.cgi?id=816396
# author: cfu@redhat.com
# Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1308019
#Patch26:        jss-support-TLS1_1-TLS1_2.patch
(Reporter)

Updated

10 months ago
Target Milestone: --- → 4.4
(Reporter)

Updated

7 months ago
Attachment #8843535 - Flags: review?(cfu)
You need to log in before you can comment on or make changes to this bug.