Closed Bug 1308099 Opened 3 years ago Closed 3 years ago

Rename AnimationPhase::Null to AnimationPhase::Idle.

Categories

(Core :: DOM: Animation, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox54 --- fixed

People

(Reporter: mantaroh, Assigned: mantaroh)

References

()

Details

Attachments

(2 files)

Web Animation spec defines the idle phase.[1]

[1] https://w3c.github.io/web-animations/#idle-phase

This phase is sames as AnimationPhase::Null of gecko.
So we will need to change to the name for consistency.
Summary: Rename AnimationPhase::Null to Animation::Idle. → Rename AnimationPhase::Null to AnimationPhase::Idle.
I'm changing the code related AniamtionPhase::Null in bug 1202333.
So this bug will need to land after bug 1202333.

WIP Code: https://treeherder.mozilla.org/#/jobs?repo=try&revision=af77c5af563ea9bb47660d7f9ba63159909428c0
Assignee: nobody → mantaroh
Priority: -- → P3
I need it before working on bug 1302648.

hiro, If you have a chance to see it, Would you please confirm this patch?
Status: NEW → ASSIGNED
Comment on attachment 8830147 [details]
Bug 1308099 part 1 - Rename AnimationPhase::Null to AnimationPhase::Idle.

https://reviewboard.mozilla.org/r/107046/#review108142

LGTM.

I just notice that 'typedef mozilla::ComputedTiming::AnimationPhase AnimationPhase' in nsTransitionManager.cpp is not useful. Also 'ComputedTiming::' at [1] can be dropped.

[1] https://hg.mozilla.org/mozilla-central/file/6dccae211ae5/layout/style/nsAnimationManager.cpp#l202

Let's drop them in a follow up patch.
Attachment #8830147 - Flags: review?(hikezoe) → review+
Comment on attachment 8830157 [details]
Bug 1308099 part 2 - Remove unnecessary typedef and use defined name instead of full namespace.

https://reviewboard.mozilla.org/r/107048/#review108154

Nice!
Attachment #8830157 - Flags: review?(hikezoe) → review+
(In reply to Hiroyuki Ikezoe (:hiro) from comment #7)
> Comment on attachment 8830157 [details]
> Bug 1308099 part 2 -Remove unncessary typedef and use defined name instead
> of full namespace.
> 
> https://reviewboard.mozilla.org/r/107048/#review108154
> 
> Nice!

Thanks hiro!

I addressed commit comment typo. s/unncessary/unnecessary.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=a74646daaac9dc0bf9028bcb2738d6127a1c42f0
Pushed by mantaroh@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/28c59fd46b6f
part 1 - Rename AnimationPhase::Null to AnimationPhase::Idle. r=hiro
https://hg.mozilla.org/integration/autoland/rev/79595c80d0a0
part 2 - Remove unnecessary typedef and use defined name instead of full namespace. r=hiro
https://hg.mozilla.org/mozilla-central/rev/28c59fd46b6f
https://hg.mozilla.org/mozilla-central/rev/79595c80d0a0
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.