Closed Bug 1308133 Opened 5 years ago Closed 5 years ago

File upload broken on ScholarOne Manuscripts platform

Categories

(Core :: DOM: Core & HTML, defect, P2)

49 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1306472
Tracking Status
firefox49 --- verified
firefox50 --- verified
firefox51 --- verified
firefox52 --- verified

People

(Reporter: fxcoudert, Unassigned)

References

()

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160916101415

Steps to reproduce:

1. Go to webpage https://mc.manuscriptcentral.com/ehps-journals
2. Create an account
3. Start a new manuscript submission
4. Try to upload any file ("File upload" section)



Actual results:

A file upload box opens, but hangs there and never completes.


Expected results:

File should upload just fine. It worked with FF ≤ 48, it works will all other browsers I have tried (Chrome, Safari, Edge, Opera).
Component: Untriaged → General
Product: Firefox → Toolkit
STR:
1) Open https://mc.manuscriptcentral.com/ehps-journals
2) Login: bugzilla@yopmail.net Pwd: rAs4A3ruthUV
3) Click on "Author" > "Continue"
4) Select a file and upload the selected file



Reg range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e457582d0089f8efa6b89f112298373aa50e6e5f&tochange=29ee431f39218378889fb821d448487497a0d1fd

Bug 1270349 or bug 1268047.
Component: General → DOM
Flags: needinfo?(bzbarsky)
Keywords: regression
OS: Unspecified → All
Product: Toolkit → Core
Hardware: Unspecified → All
Blocks: 1268047
Could well be a duplicate of bug 1306472.  Will check tomorrow.
So ok, the upload process definitely has a javascript: URL returning boolean true.  If they're waiting for onload from that iframe, that could very well explain the observed symptoms.

Should retest once bug 1306472 is fixed.
Depends on: 1306472
Flags: needinfo?(bzbarsky)
In the meantime, I expect the site can work around this buy returning a string instead of a boolean from their javascript: URL, if a workaround is desired.
Priority: -- → P2
OK.  With the fix for bug 1306472 the steps in comment 1 now work.  And looking at the source of that page that does the file upload we have:

   <script src="/common/jquery.iframe-transport.js?version=4.19.0.163"></script>

which is the same file as the one I mention in bug 1307420 comment 9.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1306472
This is being tracked in the dupe bug, so removing tracking nominations.
(Removing regression keyword as the dupe has it)
Keywords: regression
Sorry, shouldn't have removed the regression keyword; making tracking flags match the dupe instead.
No longer depends on: 1306472
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.