YouTube frequently does not switch to 1080p

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: snorp, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(platform-rel ?, firefox52 affected)

Details

(Whiteboard: [platform-rel-Youtube])

Attachments

(1 attachment, 1 obsolete attachment)

This is on current Nightly. I appear to be getting VP9 with MSE, and have plenty of buffer and connection speed. Chrome on the same machine immediately jumps to 1080p. Chrome user-agent in Firefox does not change the behavior.
I've also tried in a clean profile, where I am also not logged into Google. Same behavior.
Created attachment 8798419 [details]
YouTube stats window

As you can see here, it has plenty of buffer and detects a fast connection.
Created attachment 8798421 [details]
YouTube stats window

This is a better screenshot, it shows that we're in Auto mode.
Attachment #8798419 - Attachment is obsolete: true
The URL where I'm currently seeing this is https://www.youtube.com/watch?v=UbDrtUZGHPA which does have 1080p as an option
From the screen capture, the playback window has dimensions of 1280*720. YouTube doesn't serve resolution exceeding the viewer size as it wouldn't make a visible difference. 

What if you increase the player size, or switch to full screen?

Does it make any difference?
In full screen there was no change.
Hmm. Of course, now that I tested it again, it did change to 1080p after entering full screen. I swear I checked before! I'll keep an eye on it for a while.
platform-rel: --- → ?
Whiteboard: [platform-rel-Youtube]
@snorp - I'm closing this as WORKSFORME.  Please reopen if you see a problem.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.