Closed Bug 13082 Opened 20 years ago Closed 20 years ago

[DOGFOOD] "File | Exit" on messenger doesn't exit the app.

Categories

(MailNews Core :: Backend, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 12893

People

(Reporter: sspitzer, Assigned: don)

Details

"File | Exit" when running messenger doesn't exit the app.
linux, 12:30 am build from sep 03.

hitting the X on the window does cause it to exit.

when I do a "File | Exit"  I see this on the console:
Created nsEditorShell
data point:  "File | Quit" when running the brower works.
QA Contact: lchiang → nbaca
I believe this is a duplicate of Bug #12893 which i filed a little ways back. At
least the part about creating an ender instance is. I looked into it before
filing the bug on xpapps and thought I determined it wasn't a mailnews bug.
Assignee: putterman → don
This is happening because the exit code in globalOverlay.js is creating an
editorAppShell and then calling the Editor's version of Exit.  I can't imagine
that this is correct.  The browser calls into its appcore which I don't think is
the correct thing to do either because it's not very reusable.  Perhaps the
browser's implementation, should be moved into globalOverlay.js?

reassigning to Don because I think XPApps is dealing with these issues.
Don, this is a dup of #12893 which I also assigned to you.
Summary: "File | Exit" on messenger doesn't exit the app. → [DOGFOOD] "File | Exit" on messenger doesn't exit the app.
Moving to DOGFOOD status. I stil believe this is a duplicate of 12893 although
the technical description here is better.
Summary: [DOGFOOD] "File | Exit" on messenger doesn't exit the app. → [DOGFOOD] [PP]"File | Exit" on messenger doesn't exit the app.
Putting on [PP] list.
OS: Linux → All
Hardware: PC → All
Summary: [DOGFOOD] [PP]"File | Exit" on messenger doesn't exit the app. → [DOGFOOD] "File | Exit" on messenger doesn't exit the app.
I believe davidm took the original bug that this one is a dup of. Adding davidm
to the cc list.

removing Jan's PP comment because this is on all platforms. chanign OS to all as
well.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Yet another dup.


*** This bug has been marked as a duplicate of 12893 ***
Status: RESOLVED → VERIFIED
verified as duplicate.  The duplicate bug is marked fixed, but not yet verified.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.