Closed Bug 1308371 Opened 6 years ago Closed 6 years ago

Fix lint job so it can be unhidden

Categories

(Firefox for Android Graveyard :: Testing, defect)

defect
Not set
normal

Tracking

(firefox52 fixed)

RESOLVED FIXED
Firefox 52
Tracking Status
firefox52 --- fixed

People

(Reporter: philor, Assigned: kats)

References

Details

Sure wish someone had actually given a shred of thought to how having tier-2 jobs would actually work.

lint is hidden on all trunk trees for https://treeherder.mozilla.org/logviewer.html#?job_id=4608421&repo=autoland / https://queue.taskcluster.net/v1/task/KSRF1-5tSaObHSWq-4GcJw/runs/0/artifacts/public/android/lint/lint-results-automationDebug.html caused by bug 1235513. Needinfo me to unhide it when it's fixed, since that's apparently my sole and personal responsibility too.
(In reply to Phil Ringnalda (:philor) from comment #0)
> Sure wish someone had actually given a shred of thought to how having tier-2
> jobs would actually work.
> 
> lint is hidden on all trunk trees for
> https://treeherder.mozilla.org/logviewer.html#?job_id=4608421&repo=autoland
> /
> https://queue.taskcluster.net/v1/task/KSRF1-5tSaObHSWq-4GcJw/runs/0/
> artifacts/public/android/lint/lint-results-automationDebug.html caused by
> bug 1235513. Needinfo me to unhide it when it's fixed, since that's
> apparently my sole and personal responsibility too.

I'm confused.  I made the lint job "work", in that it correctly displays a (somewhat) helpful error:

13:49:43 INFO - TEST-UNEXPECTED-FAIL | android-lint | Lint found errors in the project; aborting build. See the report at: https://queue.taskcluster.net/v1/task/KSRF1-5tSaObHSWq-4GcJw/runs/0/artifacts/public/android/lint/lint-results-automationDebug.html 

Tier-2 jobs are explicitly such that they don't require offending patches to get backed out, so this error isn't "criticial".

philor: is your frustration that Tier-2 busting jobs aren't getting bugs filed by anybody other than you?  That the bugs aren't getting addressed?  Is my (our?) understanding of Tier-2 jobs incorrect?
Flags: needinfo?(philringnalda)
The theory behind the creation of tier-2 jobs was that someone would do some magical something somehow to treeherder so that permaorange would somehow in some unimaginable way become tolerable despite being visible.

There is no magic. A tier-2 job that's permaorange is still in the N/P keyboard cycle, still included in the unstarred count, still causes changes in the unstarred count in the tab title causing a color change saying there's something in a pinned tab which must be dealt with, still has the same visible appearance as a real failure. That makes having it visible during the periods of permaorange which the tree rules absolutely require for it unacceptable, so instead we're going to have this system where it gets ignored for hours (I know some, perhaps all, of the paid sheriffs just hide all tier-2, either part or all of the time), and then I file the bug about it, pissed off as always, and then I hide it.
Flags: needinfo?(philringnalda)
Imma fix this, philor. Just for you!
Assignee: nobody → bugmail
Removing the two xml files it's complaining about fixed the lint job for me locally. sebastian gave r+ on IRC, so I'll just land it.
https://hg.mozilla.org/mozilla-central/rev/847a2c97b414
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Unhidden.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.