mozregression mixes up fromchange and tochange on the autoland branch

RESOLVED WORKSFORME

Status

Testing
mozregression
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
I'd noticed that some recent regression reports from Softvision were getting stuck on a mozilla-central merge push without further bisection within that range, even for recent bugs.

I tried bisecting one of those reports myself yesterday and found that it was dying on an autoland push to mozilla-central where it was flipping around the fromchange and tochange arguments in the pushlog (i.e. fromchange=<bad rev>&tochange=<good>), which was of course causing failures trying to get autoland revs to test due to the broken pushlog range. I was able to confirm that manually bisecting with --repo autoland and the proper --good and --bad set worked just fine.
(Reporter)

Comment 1

2 years ago
Bug 1307439 was the one I was bisecting if you want to see the behavior for yourself. You can give it a good/bad range of 2016-09-29 and 2016-10-02 to save time.
Paul, do you want to try your hand at investigating this?
Flags: needinfo?(pyang)

Comment 3

2 years ago
I'll check it this week and see we can come out solution. leave ni? for tracking.

Comment 4

2 years ago
Ryan, I tried 'mozregression --repo autoland --good 2016-09-29 --bad 2016-10-02' on ubuntu and can't reproduce it.  Can you help to provide command? thanks.
Flags: needinfo?(pyang) → needinfo?(ryanvm)
(Reporter)

Comment 5

2 years ago
The issue was in switching over from bisection on mozilla-central *to* the autoland branch. Adding --repo autoland from the beginning is not part of the steps to reproduce.
Flags: needinfo?(ryanvm)

Comment 6

2 years ago
Just tried from autoland to mozilla-central and it works.
Will see mozilla-central to autoland later.

Comment 7

2 years ago
environment: ubuntu 64bit ver.16.04

STR
1. mozregression --repo central --good 2016-10-16 --bad 2016-10-17
2. [bad, good] Switching to autoland
3. [good, bad, bad, bad, bad] Switching to m-c
4. [good, good] Switching to inbound
5. Keep typing bad till it stopped

result: displaying https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=96d1b7238832ebf3e7e03053db19a8e557f6ca42&tochange=07276d294e171f5b7b302499049335ac9be58d96

Not seeing problem so far, need more information to clarify.
(Reporter)

Comment 8

2 years ago
Oddly, I can't reproduce either now using the STR from comment 1. Guess I'll call it WFM for now and reopen if it happens again.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.